Ask Your Question

Glance on Mitaka - change endpoint for better performance

asked 2016-09-06 15:32:40 -0500

shorton gravatar image

Hello, I have existing, working Mitaka deployment on servers with 1GbE Ethernet (external network). I have added an additional 10GbE ethernet network plane on each of my hosts for application traffic (internal network). Per the Mitaka/Glance install documentation for Ubuntu, Glance is using the 1GbE External network. Can someone give me detailed list of what needs to be changed to move Glance file transfers (REST operations?) to the 10Gbe Internal network. Which of the endpoints do I need to change: public, admin, internal? I also think I need to update Nova.conf. What else? thank you

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2016-09-06 17:30:39 -0500

updated 2016-09-06 17:33:33 -0500

swap out the hostname/ip to the ip of the 10gbe interface:

Original interface (eth0) (

10Gbe interface (eth1) (

edit the /etc/glance/glance-registry.conf :

# bind_host =
bind_host =

and i believe from the /etc/nova/nova.conf


Restart both.

edit flag offensive delete link more

answered 2016-09-07 13:51:40 -0500

shorton gravatar image

updated 2016-09-08 10:20:58 -0500

Thanks bcollins, but I don't have osapi_volume_listen in nova.conf.

I tried modifying glance-registry.conf and glance-api.conf and set bind_host= inside each, and restarted glance-registry, glance-api and nova services. However, glance image-list gave an error (could not find the endpoint). So then, I went into mysql; use keystone, select * from endpoint and modified the public, internal, and admin endpoints for glance to be instead of http://controller:9292 (

After that, glance image-list worked, but the Horizon UI gave lots of Oops errors, so I got scared and put it all back. Anyone else have any ideas?


Ok, I think I have it working now. Thanks bcollins for the suggestions; they helped. I am on Mitaka on Ubuntu 16.04.

  1. Edit /etc/cinder/cinder.conf change glance_api_servers = http://controller:9292 to: glance_api_servers = http://10GBE_IP:9292

  2. Edit /etc/nova/nova.conf change api_servers = http://controller:9292 to: api_servers = http://10GBE_IP:9292

  3. Need to update the endpoints in the database for everything to work. sudo mysql -u root -p use keystone; select * from endpoint; (here look for the 3 endpoints with port 9292 - these are the admin, internal and public endpoints for glance; we will change all 3) update endpoint set url="http://10GBE_IP:9292" where id="<uuid1>"; update endpoint set url="http://10GBE_IP:9292" where id="<uuid2>"; update endpoint set url="http://10GBE_IP:9292" where id="<uuid3>"; quit;

  4. I rebooted, but I guess you could restart nova, cinder, and apache2 for horizon. After boot-up, I verified in Horizon->Admin->System Information that glance service was listed on my new 10GBE_IP address instead of the 'controller' IP, which was the original 1GBE interface. Checked /var/log/ files for errors, so far, so good. I launched a VM and used 'netstat | grep 9292" on the controller node to verify that the VM image transfer was using the 10GBE.

  5. Your compute nodes need the update 1) and 2) above to Nova and Cinder.

thanks, shorton

edit flag offensive delete link more


im on mitaka. you may have just a volume_listen... what version are you on? also that mean glance was working but nova may not have been. you are on the right track..

grep '' /etc/nova/* 
grep' /etc/glance/*
see just values in file: grep -v '^$\|#' filename
bcollins gravatar imagebcollins ( 2016-09-08 00:27:01 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-09-06 15:32:40 -0500

Seen: 467 times

Last updated: Sep 08 '16