Ask Your Question
0

Error during LBAAS installation (Load Balancer)

asked 2016-09-05 07:23:04 -0600

Diego García gravatar image

updated 2016-09-12 11:14:22 -0600

rbowen gravatar image

Hi everybody. I have a problem with the lbaas installation. I have installed Openstack (Mitaka RDO packstack) in three nodes (Controller, network and compute) on Proxmox/KVM-hypervisor. Each node is a VM with CentOs 7. Opensatck works fine, but i need the Load balancer for more later create a a auto-scaling group with AWS EC2.

First of all, i tried install LBAAS during the initial RDO installation with the answer.txt file (CONFIG_LBAAS_INSTALL=y), but when Puppet install Neutron, the installation fails. If i put CONFIG_LBAAS_INSTALL=nin the same answer.txt file, the Openstack installation is ok. So i am trying install LBAAS following this steps: http://linuxpitstop.com/install-and-c...

First, i install haproxy and opensatck_lbaas:

yum install haproxy openstack-neutron-lbaas

Now, in the Controller node, i added this line in the "/etc/neutron/neutron_lbaas.conf" file:

service_provider = LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

And i add following parameter in /etc/neutron/neutron.conf file:

service_plugins = lbaas

Finally i restart neutron service by using the following command:

systemctl restart neutron-server.service

But I get the following error:

[root@controller ~]# systemctl restart neutron-server.service
Job for neutron-server.service failed because the control process exited with error code. See "systemctl status neutron-server.service" and "journalctl -xe" for details.
[root@controller ~]# systemctl status neutron-server.service
? neutron-server.service - OpenStack Neutron Server
   Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since lun 2016-09-05 12:28:31 CEST; 16s ago
  Process: 3873 ExecStart=/usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-dir /usr/share/neutron/server --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --config-dir /etc/neutron/conf.d/common --config-dir /etc/neutron/conf.d/neutron-server --log-file /var/log/neutron/server.log (code=exited, status=1/FAILURE)
 Main PID: 3873 (code=exited, status=1/FAILURE)

sep 05 12:28:29 controller systemd[1]: Starting OpenStack Neutron Server...
sep 05 12:28:29 controller neutron-server[3873]: Guru mediation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer ...e reports.
sep 05 12:28:30 controller neutron-server[3873]: Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.
sep 05 12:28:30 controller neutron-server[3873]: Option "notification_driver" from group "DEFAULT" is deprecated. Use option "driver" from group "oslo_messaging...ications".
sep 05 12:28:31 controller systemd[1]: neutron-server.service: main process exited, code=exited, status=1/FAILURE
sep 05 12:28:31 controller systemd[1]: Failed to start OpenStack Neutron Server.
sep 05 12:28:31 controller systemd[1]: Unit neutron-server.service entered failed state.
sep 05 12:28:31 controller systemd[1]: neutron-server.service failed.
Hint: Some lines were ellipsized, use -l to show in full.
[root@controller ~]#

And seeing the neutron log, when the lbaa's plugin load, appear the error:

2016-09-05 12:28:31.444 3873 ERROR neutron.services.service_base [-] Error loading provider 'neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver' for service LOADBALANCER

The log file ... (more)

edit retag flag offensive close merge delete

Comments

enable debug in both neutron and the lbaas.conf
I have run a packstack with mitaka and was successful in installing lbass

bcollins gravatar imagebcollins ( 2016-09-12 13:32:26 -0600 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2016-09-13 11:38:20 -0600

Appa gravatar image

This has been worked for me. But haproxy is showing error backend not available.

yum install python-neutron-lbaas yum install openstack-neutron-lbaas openstack-service status neutron-lbaas-agent yum install haproxy service neutron-lbaasv2-agent start neutron-db-manage --subproject neutron-lbaas upgrade head

Update /etc/neutron/neutron.conf service_plugins =router,metering,neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2 [service_providers] service_provider=LOADBALANCERV2:Haproxy:neutron_lbaas.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

Update /etc/neutron/lbaas_agent.ini device_driver = neutron_lbaas.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver ovs_integration_bridge = br-ex interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver

Start haproxy, lbaasv2 agent and restart neutron.

edit flag offensive delete link more

Comments

Hi Appa! many thanks. But i have one question. Where i must install python-neutron-lbaas, openstack-neutron-lbaas and haproxy?? In the Controller node? or in the Network node?

A greeting. Diego

Diego García gravatar imageDiego García ( 2016-09-15 13:27:02 -0600 )edit
0

answered 2016-09-13 08:05:21 -0600

Diego García gravatar image

Hi bcollins, thanks for your response. I can install lbaas with packstack (RDO Mitaka) in --allinone mode and 2 nodes (Controller and Compute). The problem is when i try install in 3 nodes (Controller, Compute and Network). When I install neutron-server in other node different to the Controller. The RDO installation fails. The error is:

Applying 192.168.112.220_neutron.pp
192.168.112.220_neutron.pp:                          [ DONE ]
192.168.112.219_nova.pp:                             [ DONE ]
192.168.112.210_nova.pp:                             [ DONE ]
Applying 192.168.112.210_neutron.pp
Applying 192.168.112.219_neutron.pp
192.168.112.219_neutron.pp:                          [ DONE ]
192.168.112.210_neutron.pp:                       [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.112.210_neutron.pp
Error: /Stage[main]/Neutron::Server/Service[neutron-server]: Failed to call refresh: Could not restart Service[neutron-server]: Execution of '/usr/bin/systemctl restart neutron-server' returned 1: Job for neutron-server.service failed because the control process exited with error code. See "systemctl status neutron-server.service" and "journalctl -xe" for details.
You will find full trace in log /var/tmp/packstack/20160913-120419-CQU5xG/manifests/192.168.112.210_neutron.pp.log
Please check log file /var/tmp/packstack/20160913-120419-CQU5xG/openstack-setup.log for more information
Additional information:
 * File /root/keystonerc_admin has been created on OpenStack client host 192.168.112.210. To use the command line tools you need to source the file.
 * NOTE : A certificate was generated to be used for ssl, You should change the ssl certificate configured in /etc/httpd/conf.d/ssl.conf on 192.168.112.210 to use a CA signed cert.
 * To access the OpenStack Dashboard browse to https://192.168.112.210/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.
 * To use Nagios, browse to http://192.168.112.210/nagios username: nagiosadmin, password: 01b2b9b737d34345
[root@controller ~]#

Seems that the neutron-server don't start.

[root@controller ~]# cat /var/tmp/packstack/20160913-120419-CQU5xG/manifests/192.168.112.210_neutron.pp.log
Warning: Scope(Class[Neutron::Server]): identity_uri, auth_tenant, auth_user, auth_password, auth_region configuration options are deprecated in favor of auth_plugin and related options
Notice: Compiled catalog for controller.localdomain in environment production in 14.40 seconds
Notice: /Stage[main]/Neutron/Neutron_config[DEFAULT/service_plugins]/value: value changed 'router,metering' to 'lbaas,router,metering'
Notice: /Stage[main]/Neutron::Server/Neutron_config[DEFAULT/rpc_workers]/value: value changed '2' to '6'
Notice: /Stage[main]/Neutron::Server/Neutron_config[DEFAULT/api_workers]/value: value changed '2' to '6'
Notice: /Stage[main]/Main/Package[neutron-lbaas-agent]/ensure: created
Notice: /Stage[main]/Neutron::Plugins::Ml2/Neutron_plugin_ml2[ml2/mechanism_drivers]/value: value changed 'openvswitch,linuxbridge' to 'openvswitch'
Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Triggered 'refresh' from 1 events
Notice: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: Triggered 'refresh' from 5 events
Error: /Stage[main]/Neutron::Server/Service[neutron-server]: Failed to call refresh: Could not restart Service[neutron-server]: Execution of '/usr/bin/systemctl restart neutron-server' returned 1: Job for neutron-server.service failed because the control process exited with error code. See "systemctl status neutron-server.service" and "journalctl -xe" for ...
(more)
edit flag offensive delete link more

Comments

enable debug in the neutron.conf and restart. i believe something is wrong with your lbass configuration as well. Please follow this guide and remove your lbass packages, neutron completly: wipe openstack: for i in cat servers_list ;do ssh $i yum erase openstack-{,*} -y ;done

bcollins gravatar imagebcollins ( 2016-09-13 18:32:39 -0600 )edit

to remove just neutron yum erase openstack-{,neutron}

bcollins gravatar imagebcollins ( 2016-09-13 18:36:36 -0600 )edit

once you have done this either configure packstack to install the components you need with an answer file, or add back the packages by hand following the install guides and configuration ref at http://docs.openstack.org/mitaka/conf...

bcollins gravatar imagebcollins ( 2016-09-13 18:59:06 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-05 07:23:04 -0600

Seen: 567 times

Last updated: Sep 13 '16