Ask Your Question

How to install LBaaS v 2.0 dashboard panels in Horizon (Packstack installation)

asked 2016-09-04 03:44:58 -0500

Joe2006 gravatar image

updated 2016-09-04 03:45:53 -0500

Hi, after installing and successfully deploying LBaaS v2 I am facing a problem

Installing The LBaaS v 2.0 panel into Horizon. Now I can use LBaaS v2 from CLI

Only which is fine But it takes a lot of time to build a setup that can be done in

A few minutes using Horizon.

I could not find a working solution for PackStack all in one setup as this is my test/training setup.

If anyone knows how to fix this, I will be really thankful...

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted

answered 2016-09-09 10:29:02 -0500

Diego García gravatar image

Hello, I was in the same situation as you. And I could install LBAASv2 in Horizon. Works perfect in Mitaka. You must follow these steps:

Clone the neutron-lbaas-dashboard repository:

$ git clone
$ cd neutron-lbaas-dashboard

Install the Dashboard panel plug-in:

$ python install

And now you must Copy the file from the neutron-lbaas-dashboard/enabled directory into the Dashboard openstack_dashboard/local/enabled directory

Enable the plug-in in Dashboard by editing the file and setting enable_lb to True in the OPENSTACK_NEUTRON_NETWORK dictionary. In my case, that value was already in True

If Dashboard is configured to compress static files for better performance (usually set through COMPRESS_OFFLINE in, optimize the static files again:

$ ./ collectstatic
$ ./ compress

This last command didn't work. I don't know why.

And final, restart Apache(httpd) to activate the new panel:

$ service httpd restart

If you have any questions about where the files are, tell me about.

Greetings and hopefully this will work.

The source of the information is (

edit flag offensive delete link more


Hello, thanks for you great answer! I followed this guide step-by-step, also with the link that you provided ... but I'm not able to see the Load Balancer section in the horizon dashboard. Do you have any information about why this is happening? (I already delete the caché and still the same)

jorgutpar gravatar imagejorgutpar ( 2017-03-21 06:54:55 -0500 )edit

I will answer myself and I have to say that you also have to put the file into the directory

jorgutpar gravatar imagejorgutpar ( 2017-03-23 08:04:42 -0500 )edit

Hello, I followed these steps however, the ./manage commands do not work. I get a ImportError: No module named openstack_dashboard.settings error. I am using the ocata release of packstack. Any help would be appreciated.

Jamie gravatar imageJamie ( 2017-06-14 09:46:51 -0500 )edit

I got the same, but when I used this address " /usr/share/openstack-dashboard/ " instead, it's worked fine

scarface gravatar imagescarface ( 2018-06-23 23:52:37 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2016-09-04 03:44:58 -0500

Seen: 2,178 times

Last updated: Sep 09 '16