Ask Your Question
0

How enable & use LBaaS v2.0 instead of LBaaS v1.0 in Packstack? [closed]

asked 2016-09-02 21:41:11 -0500

Joe2006 gravatar image

updated 2016-09-02 21:42:03 -0500

Hi, I got confused here! I installed Mitaka using Packstack all in one but I enabled LBaas in the Answer file and it worked fine but I found out that this is LBaaS v1.0 not the current LBaaS v2.0 As you can see in this screen cap :

image description

There are many advantages in LBaaS v2.0 and I do not understand why isn't it the default in Packstack

And I reallyI need some help on how to change to LBaaS v2.0

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Joe2006
close date 2016-09-04 03:46:55.275308

Comments

But Document mentioned LBaas v1 is deprecated in Liberty, So ideally v2 should be default in mitaka.

-> LBaaS v1: introduced in Juno (deprecated in Liberty)

sunnyarora gravatar imagesunnyarora ( 2016-09-02 22:52:22 -0500 )edit

@sunnyarora Thanks for the response, yes I saw this document but as you can see this is the UI of LBaaS v1.0 !

Joe2006 gravatar imageJoe2006 ( 2016-09-02 23:13:24 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2016-09-02 23:42:51 -0500

sunnyarora gravatar image

Seems, Its default v1 showing in mitaka. Below are the suggested changes to get LBaas v2.0 running for packstack, but before making any changes, Please take backup of the files which you are making changes.

In /etc/neutron/neutron.conf comment the existing line for service_plugins and add below line.

service_plugins = neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2,neutron.services.l3_router.l3_router_plugin.L3RouterPlugin

In /etc/neutron/neutron_lbaas.conf if this file is not there, create it. Comment the existing line for service_provider and add below line.

service_provider = LOADBALANCERV2:Haproxy:neutron_lbaas.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

In /etc/neutron/lbaas_agent.ini, comment the existing line for device_driver and add below line.

device_driver = neutron_lbaas.drivers.haproxy.namespace_driver.HaproxyNSDriver

Then, You need run below commands.

# neutron-db-manage --service lbaas upgrade head
# systemctl disable neutron-lbaas-agent.service
# systemctl stop neutron-lbaas-agent.service
# systemctl restart neutron-server.service
# systemctl enable neutron-lbaasv2-agent.service
# systemctl start neutron-lbaasv2-agent.service

Verify that lbaasv2 agent is running.

ps -ef | grep 'neutron-lbaasv2'  |grep -v grep

Then you need to create Loadbalancer using LbaaSv2, listener in that Loadbalancer, pool in that listener

Reference: Please refer to this article

edit flag offensive delete link more

Comments

@sunnyarora Thanks for the help but still there are some problmes. I followed every step you wrote and I didn't get any errors when I ran the commands but now the load balancer option is gone from Horizon and even the VPN &Firewall were gone too but I fixed that Now no LBaas in Horizon

Joe2006 gravatar imageJoe2006 ( 2016-09-03 03:10:24 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-02 21:41:11 -0500

Seen: 1,462 times

Last updated: Sep 02 '16