Ask Your Question
0

Confused about physnet1

asked 2013-12-30 12:39:45 -0500

mili gravatar image

updated 2013-12-30 13:40:19 -0500

Hi,

I have setup neutron fully according to ubuntu installation guide. My environment is HAVANA on ubuntu 12.0.4. I ave dedicated network node, dedicated controll node and dedicated compute node. I'm useing VLANS

The last step of configuring neutron is setting up the base network with the command: neutron net-create ext-net --router:external=True --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 1002

I get he error : 400-{u'NeutronError': {u'message': u'Invalid input for operation: Unknown provider:physical_network physnet1.', u'type': u'InvalidInput', u'detail': u''}}

I was searching a bit to figure out my problem but no luck. I'm now thinking that instead of physnet1 i should use my data interface on my neutron node ie eth1.

Please advice as I really dont know what is happening here.

Cheers

UPDATE:

Hi SamYaple,

Thanks for the quick response, Below is my configuration on the network node #/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:

network_vlan_ranges = physnet1:1000:2999 bridge_mappings = physnet1:br-eth1

And this is what i have on the controller node: network_vlan_ranges = physne1:1000:2999 I dont have bridge_mappings on the controller node.

I have not changed anything and dont know what to do, Here is the server log from the controller: 2013-12-30 19:23:24.099 1390 ERROR neutron.api.v2.resource [-] create failed 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource Traceback (most recent call last): 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/api/v2/resource.py", line 84, in resource 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource result = method(request=request, *args) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/api/v2/base.py", line 405, in create 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource obj = obj_creator(request.context, *kwargs) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 472, in create_network 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource network['network']) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 460, in _process_provider_create 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource raise q_exc.InvalidInput(error_message=msg) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource InvalidInput: Invalid input for operation: Unknown provider:physical_network physnet0. 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource

and also open-vswich log on the controller: ---> looks like im in trouble Command: ['ip', '-o', 'link', 'show', 'br-int'] Exit code: 1 Stdout: '' Stderr: 'Device "br-int" does not exist.\n'

I only have one nic on the controller node and it is for management. I can add another if I have to

I just turned verborse and debugging on, will I see it on the console or the logfile?

edit retag flag offensive close merge delete

Comments

I think my configuration for the controler node is not complete, I have looked at the tuturial over and over but cant figure this out.

mili gravatar imagemili ( 2013-12-30 15:09:57 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-12-30 13:27:37 -0500

mili gravatar image

Hi SamYaple,

Thanks for the quick response, Below is my configuration on the network node #/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:

network_vlan_ranges = physnet1:1000:2999 bridge_mappings = physnet1:br-eth1

And this is what i have on the controller node: network_vlan_ranges = physne1:1000:2999 I dont have bridge_mappings on the controller node.

I have not changed anything and dont know what to do, Here is the server log from the controller: 2013-12-30 19:23:24.099 1390 ERROR neutron.api.v2.resource [-] create failed 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource Traceback (most recent call last): 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/api/v2/resource.py", line 84, in resource 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource result = method(request=request, *args) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/api/v2/base.py", line 405, in create 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource obj = obj_creator(request.context, *kwargs) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 472, in create_network 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource network['network']) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 460, in _process_provider_create 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource raise q_exc.InvalidInput(error_message=msg) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource InvalidInput: Invalid input for operation: Unknown provider:physical_network physnet0. 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource

and also open-vswich log on the controller: ---> looks like im in trouble Command: ['ip', '-o', 'link', 'show', 'br-int'] Exit code: 1 Stdout: '' Stderr: 'Device "br-int" does not exist.\n'

I only have one nic on the controller node and it is for management. I can add another if I have to

I just turned verborse and debugging on, will I see it on the console or the logfile?

edit flag offensive delete link more

Comments

Please update your original question with this information. Debugging will appear in your log file. br-int means you haven't setup your bridge yet. Please follow your guide more closely for that. the command is `ovs-vsctl add-br br-int`

SamYaple gravatar imageSamYaple ( 2013-12-30 13:36:20 -0500 )edit

Sorry for posting as an answer.

mili gravatar imagemili ( 2013-12-30 13:45:13 -0500 )edit

No problem, you can remove the answer since you updated your question.

SamYaple gravatar imageSamYaple ( 2013-12-30 13:56:03 -0500 )edit

I looked at the tuturial again but did not find a section to talking about ovs-vsctl add-br br-int` for the controller node. I have br-eth1,br-ex,br-int,eth2,eth3 on my network node

mili gravatar imagemili ( 2013-12-30 14:24:03 -0500 )edit

It is in the guide. You have br-int on your network node. You need it on the compute node as well.

SamYaple gravatar imageSamYaple ( 2013-12-30 15:09:22 -0500 )edit
0

answered 2013-12-30 12:51:00 -0500

SamYaple gravatar image

updated 2013-12-30 12:51:55 -0500

You need to configure physnet1 to a bridge. See the line below:

#/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
[ovs]
#change br-eth0 to your "data network" bridge
bridge_mappings = physnet1:br-eth0
network_vlan_ranges = physnet1

In addition, turning on verbose and debugging mode in the neutron conf can help alot in tracking down this issue.

#/etc/neutron/neutron.conf
[DEFAULT]
verbose = True
debug = True
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-30 12:39:45 -0500

Seen: 3,737 times

Last updated: Dec 30 '13