Unable to launch an instance in Openstack

asked 2016-09-01 08:51:59 -0500

Anurag Anand gravatar image

updated 2016-09-01 08:52:48 -0500

Hello

Whenever i am trying to launch an instance in Openstack it is failing and giving me the error as :

"Failed to perform the requested operation on instance "testvm" ,the instance has an error status.Please try again later.[Error : build instance aborted :Unable to establish connection to http://127.0.0.1:9696/v2.0/extension.json]%22 (http://127.0.0.1:9696/v2.0/extension....)

Please do check and respond. Thank You .

edit retag flag offensive close merge delete

Comments

Please check error messages in nova-compute.log and nova-scheduler.log

Praveen N gravatar imagePraveen N ( 2016-09-01 10:37:57 -0500 )edit

How many nodes do you have? check why it cannot establish a connection with your neutron server

fifi gravatar imagefifi ( 2016-09-01 14:38:23 -0500 )edit

Thanks for your reply. There is no error messages in any nova log file it is perfectly fine. Only when I am checking the keystone log file it is returning am error : Err 98. Address already in use and admin server not started.-= Praveen N =-

Anurag Anand gravatar imageAnurag Anand ( 2016-09-01 15:31:32 -0500 )edit

Thanks for your reply. I have 2 nodes. Compute and controller. I have only installed nova. Neutron. Glance. Identity services on them. Checked every service log file and it is all good. Only the keystone log file is returning an error :- error 98 address already in use. And admin server not started.

Anurag Anand gravatar imageAnurag Anand ( 2016-09-01 15:37:11 -0500 )edit