Ask Your Question
2

nova service-list raises "Error setting Service.id" with nova-cell installed

asked 2013-12-30 05:05:20 -0500

huwei-xtu gravatar image
大家

updated 2014-01-03 17:21:48 -0500

smaffulli gravatar image

Installed all-in-one mode by devstack with the following localrc:

  ADMIN_PASSWORD=passw0rd
  MYSQL_PASSWORD=root
  RABBIT_PASSWORD=stackqueue
  SERVICE_PASSWORD=$ADMIN_PASSWORD
  LOGFILE=$DEST/logs/stack.sh.log
  LOGDAYS=2

  CINDER_BRANCH=stable/havana
  GLANCE_BRANCH=stable/havana
  HORIZON_BRANCH=stable/havana
  KEYSTONE_BRANCH=stable/havana
  KEYSTONECLIENT_BRANCH=stable/havana
  NOVA_BRANCH=stable/havana
  NOVACLIENT_BRANCH=stable/havana
  NEUTRON_BRANCH=stable/havana
  SWIFT_BRANCH=stable/havana

  SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5
  SWIFT_REPLICAS=1

  SWIFT_DATA_DIR=$DEST/data


  FLOATING_RANGE=192.168.0.224/27
  FIXED_RANGE=10.10.1.0/24
  FIXED_NETWORK_SIZE=256
  FLAT_INTERFACE=eth1

  disable_service n-net
  enable_service q-svc
  enable_service q-agt
  enable_service q-dhcp
  enable_service q-l3
  enable_service q-lbaas
  enable_service q-meta
  enable_service q-metering
  enable_service neutron
  # Optional, to enable tempest configuration as part of DevStack
  enable_service tempest
  enable_service heat h-api h-api-cfn h-api-cw h-eng
  enable_service n-cell
  SERVICE_TOKEN=passw0rd

After finished the installation, can use nova boot to boot instance, but if use "nova service-list" or "nova host-list" show the services and hosts, it will return an error msg:

2013-12-30 07:56:14.910 ERROR object [req-005a967f-97be-4401-8afb-c0c562402405 admin admin] Error setting Service.id
2013-12-30 07:56:14.910 TRACE object Traceback (most recent call last):
2013-12-30 07:56:14.910 TRACE object   File "/opt/stack/nova/nova/objects/base.py", line 70, in setter
2013-12-30 07:56:14.910 TRACE object     field.coerce(self, name, value))
2013-12-30 07:56:14.910 TRACE object   File "/opt/stack/nova/nova/objects/fields.py", line 166, in coerce
2013-12-30 07:56:14.910 TRACE object     return self._type.coerce(obj, attr, value)
2013-12-30 07:56:14.910 TRACE object   File "/opt/stack/nova/nova/objects/fields.py", line 231, in coerce
2013-12-30 07:56:14.910 TRACE object     return int(value)
2013-12-30 07:56:14.910 TRACE object ValueError: invalid literal for int() with base 10: 'region!child@1'
2013-12-30 07:56:14.910 TRACE object 
2013-12-30 07:56:14.917 ERROR nova.api.openstack [req-005a967f-97be-4401-8afb-c0c562402405 admin admin] Caught error: invalid literal for int() with base 10: 'region!child@1'
2013-12-30 07:56:14.917 TRACE nova.api.openstack Traceback (most recent call last):
2013-12-30 07:56:14.917 TRACE nova.api.openstack   File "/opt/stack/nova/nova/api/openstack/__init__.py", line 121, in __call__
2013-12-30 07:56:14.917 TRACE nova.api.openstack     return req.get_response(self.application)
2013-12-30 07:56:14.917 TRACE nova.api.openstack   File "/usr/local/lib/python2.7/dist-packages/webob/request.py", line 1296, in send
2013-12-30 07:56:14.917 TRACE nova.api.openstack     application, catch_exc_info=False)
2013-12-30 07:56:14.917 TRACE nova.api.openstack   File "/usr/local/lib/python2.7/dist-packages/webob/request.py", line 1260, in call_application
2013-12-30 07:56:14.917 TRACE nova.api.openstack     app_iter = application(self.environ, start_response)
2013-12-30 07:56:14.917 TRACE nova.api.openstack   File "/usr/local/lib/python2.7/dist-packages/webob/dec.py", line 144, in __call__
2013-12-30 07:56:14.917 TRACE nova.api.openstack     return resp(environ, start_response)
2013-12-30 07:56:14.917 TRACE nova.api.openstack   File "/opt/stack/python-keystoneclient/keystoneclient/middleware/auth_token.py", line 581, in __call__
2013-12-30 07:56:14.917 TRACE nova.api.openstack ...
(more)
edit retag flag offensive close delete

2 answers

Sort by » oldest newest most voted
0

answered 2014-02-23 12:33:06 -0500

I have the same issue and I believe it's a bug. I took the liberty to file a bug report copying the text of your question.

edit flag offensive delete publish link more
0

answered 2014-01-15 03:07:18 -0500

litao gravatar image

i encounter this issue , did you solve it?

edit flag offensive delete publish link more

Comments

No, from what I have debugged, I think it is a bug.

huwei-xtu ( 2014-01-15 21:33:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2013-12-30 05:05:20 -0500

Seen: 100 times

Last updated: Feb 23