Ask Your Question
0

Cloudkitty launch error on Mitaka

asked 2016-08-29 01:20:09 -0600

KotoriChannn gravatar image

updated 2016-09-02 03:51:53 -0600

HI there.

I am trying to install Cloudkitty on OpenStack Mitaka.

every previous installation step were done successfully, but i have an error on launching Cloudkitty.

cloudkitty-api --config-file /etc/cloudkitty/cloudkitty.conf

when i try to launch cloudkitty-api, i got this error.

2016-08-29 15:16:00.371 13497 INFO cloudkitty.api.app [-] Starting server in PID 13497
2016-08-29 15:16:00.394 13497 INFO cloudkitty.api.app [-] Configuration:
2016-08-29 15:16:00.395 13497 INFO cloudkitty.api.app [-] ********************************************************************************
2016-08-29 15:16:00.395 13497 INFO cloudkitty.api.app [-] Configuration options gathered from:
2016-08-29 15:16:00.395 13497 INFO cloudkitty.api.app [-] command line args: ['--config-file', '/etc/cloudkitty/cloudkitty.conf']
2016-08-29 15:16:00.395 13497 INFO cloudkitty.api.app [-] config files: ['/etc/cloudkitty/cloudkitty.conf']
2016-08-29 15:16:00.395 13497 INFO cloudkitty.api.app [-] ================================================================================
2016-08-29 15:16:00.395 13497 INFO cloudkitty.api.app [-] api_paste_config               = api_paste.ini
2016-08-29 15:16:00.396 13497 INFO cloudkitty.api.app [-] auth_strategy                  = keystone
2016-08-29 15:16:00.396 13497 INFO cloudkitty.api.app [-] config_dir                     = None
2016-08-29 15:16:00.396 13497 INFO cloudkitty.api.app [-] config_file                    = ['/etc/cloudkitty/cloudkitty.conf']
2016-08-29 15:16:00.396 13497 INFO cloudkitty.api.app [-] debug                          = False
2016-08-29 15:16:00.396 13497 INFO cloudkitty.api.app [-] default_log_levels             = ['amqp=WARN', 'amqplib=WARN', 'boto=WARN', 'qpid=WARN', 'sqlalchemy=WARN', 'suds=INFO', 'oslo.messaging=INFO', 'iso8601=WARN', 'requests.packages.urllib3.connectionpool=WARN', 'urllib3.connectionpool=WARN', 'websocket=WARN', 'requests.packages.urllib3.util.retry=WARN', 'urllib3.util.retry=WARN', 'keystonemiddleware=WARN', 'routes.middleware=WARN', 'stevedore=WARN', 'taskflow=WARN', 'keystoneauth=WARN', 'oslo.cache=INFO', 'dogpile.core.dogpile=INFO']
2016-08-29 15:16:00.396 13497 INFO cloudkitty.api.app [-] host                           = wehost.controller
2016-08-29 15:16:00.397 13497 INFO cloudkitty.api.app [-] instance_format                = [instance: %(uuid)s] 
2016-08-29 15:16:00.397 13497 INFO cloudkitty.api.app [-] instance_uuid_format           = [instance: %(uuid)s] 
2016-08-29 15:16:00.397 13497 INFO cloudkitty.api.app [-] log_config_append              = None
2016-08-29 15:16:00.397 13497 INFO cloudkitty.api.app [-] log_date_format                = %Y-%m-%d %H:%M:%S
2016-08-29 15:16:00.397 13497 INFO cloudkitty.api.app [-] log_dir                        = /var/log/cloudkitty
2016-08-29 15:16:00.397 13497 INFO cloudkitty.api.app [-] log_file                       = None
2016-08-29 15:16:00.397 13497 INFO cloudkitty.api.app [-] logging_context_format_string  = %(asctime)s.%(msecs)03d %(process)d %(levelname)s %(name)s [%(request_id)s %(user_identity)s] %(instance)s%(message)s
2016-08-29 15:16:00.398 13497 INFO cloudkitty.api.app [-] logging_debug_format_suffix    = %(funcName)s %(pathname)s:%(lineno)d
2016-08-29 15:16:00.398 13497 INFO cloudkitty.api.app [-] logging_default_format_string  = %(asctime)s.%(msecs)03d %(process)d %(levelname)s %(name)s [-] %(instance)s%(message)s
2016-08-29 15:16:00.398 13497 INFO cloudkitty.api.app [-] logging_exception_prefix       = %(asctime)s.%(msecs)03d %(process)d ERROR %(name)s %(instance)s
2016-08-29 15:16:00.398 13497 INFO cloudkitty.api.app [-] logging_user_identity_format   = %(user)s %(tenant)s %(domain)s %(user_domain)s %(project_domain)s
2016-08-29 15:16:00.398 13497 INFO cloudkitty.api.app [-] publish_errors                 = False
2016-08-29 15:16:00.398 13497 INFO cloudkitty.api.app [-] syslog_log_facility            = LOG_USER ...
(more)
edit retag flag offensive close merge delete

Comments

There are no errors on logs, only INFO or WARNING statements.

Antonio G. gravatar imageAntonio G. ( 2016-08-29 03:14:27 -0600 )edit

I know that theres no "ERROR" or "CRITICAL" message, but system just freeze forever after "WARNING keystonemiddleware.auth_token" error.

KotoriChannn gravatar imageKotoriChannn ( 2016-08-29 03:31:43 -0600 )edit

Is the auth_url pointing to the public identity endpoint? You can simply verify it running keystone endpoint-list with admin credentials

Antonio G. gravatar imageAntonio G. ( 2016-08-29 09:00:39 -0600 )edit

It looks fine.

Every addresses on [adminurl] are pointing the OpenStack Controller's IP correctly.

KotoriChannn gravatar imageKotoriChannn ( 2016-08-29 17:25:19 -0600 )edit

I have the same error (MissingAuthPlugin: An auth plugin is required to determine endpoint URL). [keystone_fetcher] url and [keystone_authtoken] auth_uri point to public keysone endpoint.

agti gravatar imageagti ( 2016-08-30 01:53:55 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2016-08-30 09:01:23 -0600

updated 2016-08-31 04:31:43 -0600

Try reading this. Seems official installation doc does not refer to additional config parameters:

[authinfos]
auth_type = v2password
auth_url = http://<KEYSTONE_IP>:5000/v2.0/
username = cloudkitty
password = CK_PASSWORD
tenant_name = services
region_name = RegionOne

[keystone_fetcher]
auth_section = authinfos

[ceilometer_collector]
auth_section = authinfos

[collect]
collector = ceilometer
services = compute,image,volume,network.bw.in,network.bw.out,network.floating

Those values were retrieved through reverse engineering cloudkitty devstack plugin script that configures cloudkitty config files.

ANSWER EDIT #2

Try using this config file, filled in with your values:

[DEFAULT]
debug = True
log_dir = /var/log/cloudkitty
verbose = True

[api]

[ceilometer_collector]
auth_section = authinfos

[collect]
collector = ceilometer
services = compute,image,volume,network.bw.in,network.bw.out,network.floating

[cors]

[cors.subdomain]

[database]
connection = mysql://cloudkitty:CK_DBPASS@localhost/cloudkitty

[authinfos]
auth_type = v2password
auth_url = http://<KEYSTONE_IP>:5000/v2.0/
username = cloudkitty
password = CK_PASSWORD
tenant_name = services
region_name = RegionOne

[auth]
username = cloudkitty
password = CK_PASSWORD
tenant = service
region = RegionOne
url = http://<KEYSTONE_IP>:5000/v2.0/
auth_plugin = v2password

[keystone_authtoken]
auth_uri = http://<KEYSTONE_IP>:5000/v2.0/
identity_uri = http://<KEYSTONE_IP>:5000/
admin_user = cloudkitty
admin_password = CK_PASSWORD
admin_tenant_name = admin

[keystone_fetcher]
auth_section = authinfos
keystone_version = 2
username = admin
password = admin
tenant = admin
region = RegionOne
url = http://<KEYSTONE_IP>:5000/v2.0/

[matchmaker_redis]

[matchmaker_ring]

[oslo_messaging_amqp]

[oslo_messaging_qpid]

[oslo_messaging_rabbit]
rabbit_hosts = <RABBIT_IP>:<RABBIT_PORT>
rabbit_userid = nova
rabbit_password = <RABBIT_PASSWORD>

[output]

[state]

[storage]

[tenant_fetcher]

I also noticed that you have two endpoints referring to Cloudkitty that are related to a wrong regionOne. Try deleting those and recreating one of them using command:

keystone endpoint-create --region RegionOne --service-id <Cloudkitty_service_id> --publicurl http://<IP>:8889 --adminurl http://<IP>:8889 --internalurl http://<IP>:8889

You could run Cloudkitty either on Controller Node or another Node (with connectivity to Keystone, Rabbit and Ceilometer endpoints)

ANSWER EDIT #3

Try setting port to 8889 (from 8888, the default in config file), then opening three different terminals:

1. cloudkitty-api --config-file /etc/cloudkitty/cloudkitty.conf
2. cloudkitty-processor --config-file /etc/cloudkitty/cloudkitty.conf
3. source rcfile; cloudkitty report-tenant-list;
edit flag offensive delete link more

Comments

Thanks for the reply. but unfortunately, i already added that params on my .conf file. I uploaded my .conf file on bottom of my question. Please check it.

KotoriChannn gravatar imageKotoriChannn ( 2016-08-30 23:40:49 -0600 )edit

First of all, Thank you very much. I got help a lot. but still i have a problem. Can you check my added log on bottom of my question one more time?

  • maybe it can be my system's problem. i will format my system and retry this again.
KotoriChannn gravatar imageKotoriChannn ( 2016-08-31 04:01:38 -0600 )edit

I think it is working now... ;) Try setting port to 8889

Antonio G. gravatar imageAntonio G. ( 2016-08-31 04:28:03 -0600 )edit

Sorry for keep asking. System still hold when i cloudkitty-api --config-file /etc/cloudkitty/cloudkitty.conf can you check my question one more time? i added my logs.

KotoriChannn gravatar imageKotoriChannn ( 2016-09-02 00:27:06 -0600 )edit

I think it is an expected behavior. cloudkitty-api waits for an API call (that you can test through the command cloudkitty, but it seems you do not have that command). Try installing cloudkitty (cloudkitty python client) or call the API through a REST client.

Antonio G. gravatar imageAntonio G. ( 2016-09-02 01:49:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-08-29 01:20:09 -0600

Seen: 976 times

Last updated: Sep 02 '16