tacker vnf-update results in error state of a VNF

asked 2016-08-26 00:22:09 -0600

abhilash-goyal gravatar image

updated 2016-08-26 04:59:09 -0600

I am creating openwrt VNF through the following command:

tacker vnf-create --vnfd-id <id of openwrt vnf-d> --name openwrt_1

This vnfd have three connecting points which results in creation of eth0, eth1, eth2. This vnf is getting in Active mode,but when I am trying to update this vnf by following command,

stack@abhilash-VirtualBox:~$ tacker vnf-update --config-file tosca-cirros-firewall-update.yaml     c1fe94f6-4eb1-49b1-9eaa-0e56ded15a29
Updated vnf: c1fe94f6-4eb1-49b1-9eaa-0e56ded15a29

this says that vnf updated, but results in leaving vnf in error state with reason saying 'VNF configuration failed'.

tosca-cirros-firewall-update.yaml file looks like:

vdus:
  VDU1:
    config:
      network: |
       package network
        config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
        config interface 'lan'
            option ifname 'eth0'
            option type 'bridge'
            option proto 'dhcp'
            option ip6assign '60'
        config interface 'wan'
            option ifname 'eth1'
            option proto 'dhcp'
        config interface 'wan6'
            option ifname 'eth1'
            option proto 'dhcpv6'
        config interface 'wan'
            option ifname 'eth2'
            option proto 'dhcp'
        config interface 'wan6'
            option ifname 'eth2'
            option proto 'dhcpv6'
        config globals 'globals'
            option ula_prefix 'fdb3:e323:e93b::/48'

Kindly suggest, where am I going wrong. Thanks in advance.

edit retag flag offensive close merge delete