006_mysql_upgrade.sql failed: process() takes exactly 2 arguments (3 given)

asked 2016-08-24 05:56:13 -0500

twinkie gravatar image

Hello,

i am running through the documentation for install openstack on CentOS7 despite some documentation errors and python bugs, i have all services runnning. Except the glance Image Service. I cant get it run, because the "glance-manage db_sync" fails with following log output. Can anyone give me a hint what i am doing wrong?

2016-08-24 07:05:20.606 24395 INFO migrate.versioning.api [-] 5 -> 6... 
2016-08-24 07:05:20.617 24395 ERROR migrate.versioning.script.sql [-] SQL script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/006_mysql_upgrade.sql failed: process() takes exactly 2 arguments (3 given)
2016-08-24 07:05:20.617 24395 CRITICAL glance [-] TypeError: process() takes exactly 2 arguments (3 given)
2016-08-24 07:05:20.617 24395 ERROR glance Traceback (most recent call last):
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/bin/glance-manage", line 10, in <module>
2016-08-24 07:05:20.617 24395 ERROR glance     sys.exit(main())
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/glance/cmd/manage.py", line 341, in main
2016-08-24 07:05:20.617 24395 ERROR glance     return CONF.command.action_fn()
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/glance/cmd/manage.py", line 196, in sync
2016-08-24 07:05:20.617 24395 ERROR glance     CONF.command.current_version)
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/glance/cmd/manage.py", line 120, in sync
2016-08-24 07:05:20.617 24395 ERROR glance     version)
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/oslo_db/sqlalchemy/migration.py", line 79, in db_sync
2016-08-24 07:05:20.617 24395 ERROR glance     migration = versioning_api.upgrade(engine, repository, version)
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/migrate/versioning/api.py", line 186, in upgrade
2016-08-24 07:05:20.617 24395 ERROR glance     return _migrate(url, repository, version, upgrade=True, err=err, **opts)
2016-08-24 07:05:20.617 24395 ERROR glance   File "<decorator-gen-15>", line 2, in _migrate
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/migrate/versioning/util/__init__.py", line 160, in with_engine
2016-08-24 07:05:20.617 24395 ERROR glance     return f(*a, **kw)
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/migrate/versioning/api.py", line 366, in _migrate
2016-08-24 07:05:20.617 24395 ERROR glance     schema.runchange(ver, change, changeset.step)
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/migrate/versioning/schema.py", line 93, in runchange
2016-08-24 07:05:20.617 24395 ERROR glance     change.run(self.engine, step)
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2.7/site-packages/migrate/versioning/script/sql.py", line 57, in run
2016-08-24 07:05:20.617 24395 ERROR glance     text = sqlparse.format(text, strip_comments=True, strip_whitespace=True)
2016-08-24 07:05:20.617 24395 ERROR glance   File "/usr/lib/python2 ...
(more)
edit retag flag offensive close merge delete

Comments

Please post details of configuration files -glance-api.conf and glance-registry.conf . I think glance is not able to connect to database.-thanks

sunnyarora gravatar imagesunnyarora ( 2016-08-25 21:22:31 -0500 )edit

glance seems able to connect. Database is filled and upgrade scripts 0 to 5 are completed successfully. Log of first attempt: http://pastebin.com/upmVCB6w Configuration files: http://pastebin.com/7hRf39ND

twinkie gravatar imagetwinkie ( 2016-08-26 02:42:04 -0500 )edit