Ask Your Question
0

OpenStack Liberty [Open vSwitch] - Instances have no IP address

asked 2016-08-23 10:39:40 -0500

Graham gravatar image

Hello,

I am currently trying to debug a 3-node OpenStack Liberty setup. Everything is working as intended, except that the instances I create do not get assigned an IP address. I have 3 networks:

  • Management network (10.11.19.0/24)
  • External network (10.11.17.0/24)
  • Tunnel network (10.11.20.0/24)

The two nodes on the tunnel network (compute and network nodes) cannot ping each others tunnel interfaces. Is this problematic, or do the interfaces need to be ports on the Open vSwitch bridge br-tun?

Here is my configuration:

Open vSwitch:

# ovs-vsctl show

Bridge br-int
        fail_mode: secure
        Port "qr-99b91a4a-ae"
            tag: 1
            Interface "qr-99b91a4a-ae"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port int-br-tun
            Interface int-br-tun
                type: patch
                options: {peer=phy-br-tun}
        Port "qg-3d128df7-ec"
            tag: 2
            Interface "qg-3d128df7-ec"
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port "tap56455d07-dd"
            tag: 1
            Interface "tap56455d07-dd"
                type: internal
        Port br-int
            Interface br-int
                type: internal
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth0"
            Interface "eth0"
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
    Bridge br-tun
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port phy-br-tun
            Interface phy-br-tun
                type: patch
                options: {peer=int-br-tun}
        Port br-tun
            Interface br-tun
                type: internal
        Port "vxlan-0a0b14cf"
            Interface "vxlan-0a0b14cf"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="10.11.20.206", out_key=flow, remote_ip="10.11.20.207"}
    ovs_version: "2.4.1"

Dnsmasq:

Aug 23 10:58:15 dnsmasq[22362]: started, version 2.68 cachesize 150
Aug 23 10:58:15 dnsmasq[22362]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth
Aug 23 10:58:15 dnsmasq[22362]: warning: no upstream servers configured
Aug 23 10:58:15 dnsmasq-dhcp[22362]: DHCP, static leases only on 192.168.3.0, lease time 1d
Aug 23 10:58:15 dnsmasq-dhcp[22362]: DHCP, sockets bound exclusively to interface tap56455d07-dd
Aug 23 10:58:15 dnsmasq[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/addn_hosts - 1 addresses
Aug 23 10:58:15 dnsmasq-dhcp[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/host
Aug 23 10:58:15 dnsmasq-dhcp[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/opts
Aug 23 10:58:16 dnsmasq[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/addn_hosts - 1 addresses
Aug 23 10:58:16 dnsmasq-dhcp[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/host
Aug 23 10:58:16 dnsmasq-dhcp[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/opts
Aug 23 11:04:02 dnsmasq[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/addn_hosts - 2 addresses
Aug 23 11:04:02 dnsmasq-dhcp[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/host
Aug 23 11:04:02 dnsmasq-dhcp[22362]: read /var/lib/neutron/dhcp/f7d1f5d8-ab46-4306-a02c-6b31f45734b8/opts

DHCP namespace:

# ip netns 
qrouter-0e791a5e-ec9a-46e3-998f-073eb2763d26
qdhcp-f7d1f5d8-ab46-4306-a02c-6b31f45734b8

# ip netns exec qrouter-0e791a5e-ec9a-46e3-998f-073eb2763d26 ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-10-11 21:13:42 -0500

Gaurav Goyal gravatar image

Hi ,

I am using a 2 node openstack

Node 1 --> compute + controller + network node2 --> compute1

Using 2 interfaces p5p1 --> management p5p2 --> unnumbered --> external

Actually i had setup linuxbridging as mentioned in liberty doc. Now want to move to OVS .. Can i do that with 2 interfaces making management as tunnel interface?

Unable to create instance, giving neutron error

[root@OSKVM1 ~]# neutron agent-list +--------------------------------------+--------------------+--------+-------+----------------+---------------------------+ | id | agent_type | host | alive | admin_state_up | binary | +--------------------------------------+--------------------+--------+-------+----------------+---------------------------+ | 59092c06-8468-4cdd-a53e-5ec0c4788c3d | Open vSwitch agent | OSKVM2 | :-) | True | neutron-openvswitch-agent | | 6fc714b4-de9e-4b86-8b05-f4b2589b2815 | L3 agent | OSKVM1 | :-) | True | neutron-l3-agent | | 81883be9-62ed-47fe-82e7-6cc45bdc159b | Metadata agent | OSKVM1 | :-) | True | neutron-metadata-agent | | 8d2cdf8f-0eb7-4175-aead-b6cf82a76e42 | Linux bridge agent | OSKVM2 | xxx | True | neutron-linuxbridge-agent | | acd754b8-4180-4ebf-9827-7df6524c72f1 | DHCP agent | OSKVM1 | :-) | True | neutron-dhcp-agent | | d19f9b5d-80c4-43a8-84db-5529628d10ed | Open vSwitch agent | OSKVM1 | :-) | True | neutron-openvswitch-agent | | f29cf6e8-99c5-4421-9edc-d2cf5fc20f78 | Linux bridge agent | OSKVM1 | xxx | True | neutron-linuxbridge-agent | +--------------------------------------+--------------------+--------+-------+----------------+---------------------------+

[root@OSKVM1 neutron]# ovs-vsctl show 602ca311-4ebe-4773-8d58-00d1a0161294 Bridge br-ex Port br-ex Interface br-ex type: internal Port "p5p2" Interface "p5p2" Bridge br-int fail_mode: secure Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} Port br-int Interface br-int type: internal Bridge br-tun fail_mode: secure Port "vxlan-0a180005" Interface "vxlan-0a180005" type: vxlan options: {df_default="true", in_key=flow, local_ip="10.24.0.4", out_key=flow, remote_ip="10.24.0.5"} Port br-tun Interface br-tun type: internal Port patch-int Interface patch-int type: patch options: {peer=patch-tun} ovs_version: "2.5.0"

edit flag offensive delete link more
0

answered 2016-08-23 12:59:37 -0500

Graham gravatar image

Turns out the problem was a VMware network issue. I added the tunnel NICs from my OpenStack VMs to a new virtual internal network in VMware and that fixed the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-08-23 10:39:40 -0500

Seen: 211 times

Last updated: Oct 11 '16