Ask Your Question
0

error in neutron : uable to establish connection to http://controller:9696

asked 2016-08-21 18:00:43 -0500

Eng Sarro gravatar image

Hello All,

I installed Mitaka openstack and I got the error below when I entered ( # neutron ext-list )

It seems that port 9696 is not opened and not listened as I checked that point

Could you please tell me how to open port 9696

another question : how to show /var/log/neutron/server.log file ... is it via ( # sudo vi /var/log/neutron/server.log or what ? as this command give me a new empty file )

thanks in advance and will be waiting your support,

Sarah

edit retag flag offensive close merge delete

Comments

Please provide the following info -:

  1. Output of neutron ext-list --debug
  2. Execute netstat -ano |grep 9696
  3. Execute cat /etc/neutron/neutron.conf
Mohit gravatar imageMohit ( 2016-08-22 22:13:53 -0500 )edit

1- neutron ext-list --debug it give me the same error that I put with a long log words

2- netstat -ano |grep 9696 is empty 3- cat /etc/neutron/neutron.conf

Eng Sarro gravatar imageEng Sarro ( 2016-08-27 04:03:13 -0500 )edit

[DEFAULT]

core_plugin = ml2

service_plugins = router

allow_overlapping_ips = True

rpc_backend = rabbit

auth_strategy = keystone

notify_nova_on_port_status_changes = True

notify_nova_on_port_data_changes = True

[oslo_messaging_rabbit]

rabbit_host = controller

rabbit_userid = openstack

Eng Sarro gravatar imageEng Sarro ( 2016-08-27 04:04:38 -0500 )edit

rabbit_password = 12345

[keystone_authtoken]

auth_uri = http://controller:5000

auth_url = http:// controller:35357

memcached_servers = controller:11211

auth_type = password

project_domain_name = default

user_domain_name = default

project_name = service

username = neutron

password = 12345

Eng Sarro gravatar imageEng Sarro ( 2016-08-27 04:06:03 -0500 )edit

[nova]

auth_url = http://controller:35357

auth_type = password

project_domain_name = default

user_domain_name = default

region_name = RegionOne

project_name = service

username = neutron

password = 12345

Eng Sarro gravatar imageEng Sarro ( 2016-08-27 04:06:33 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-08-22 02:52:28 -0500

yprokule gravatar image

@eng-sarro what OS U r using ? To troubleshoot connectivity I'd recommend to:

  1. Check via ping

    ping -c1 controller

  2. Check if controller is resolvable via DNS

  3. Check the firewall:

    firewall-cmd --state #RHEL based OS

    iptables -L

  4. If U ain't using HA check openstack services with

    openstack-status

  5. Check the Neutron services

    systemctl status neutron-server #RHEL based OS

edit flag offensive delete link more

Comments

I'm using Ubuntu server 14.04

1- Controller is pingable

2- Controller is resolvable

3- anywhere to anywhere

4- No HA

5- neutron service is Running normally

I know that the problem is in port 9696 as it's not open :(

Eng Sarro gravatar imageEng Sarro ( 2016-08-27 04:12:19 -0500 )edit
yprokule gravatar imageyprokule ( 2016-08-29 02:45:09 -0500 )edit

Thanks yprokule but unfortunately it didn't work with me >>> I tried to add a rule and already added it but I don't know how to create a new chain for neutron as the created one is related to nova-api ..... I searched about that but didn't find the solution

Eng Sarro gravatar imageEng Sarro ( 2016-08-29 13:08:53 -0500 )edit

So how the nova chain was created? If U followed some doc - there suppose to be reference how to do this for Neutron. Or if U used some installer it has to do this for U. Otherwise - man iptables :)

yprokule gravatar imageyprokule ( 2016-08-30 04:38:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-08-21 18:00:43 -0500

Seen: 284 times

Last updated: Aug 22 '16