Ask Your Question
0

Mitaka horizon unable to retrieve image list

asked 2016-08-18 12:17:55 -0500

ojakaja gravatar image

Hi All,

I've installed my openstack (mitaka) and so far, everything is ok except for one thing, As the question says, The dashboard cant retrieve the Image list.

I've done some debugging and found out that somehow the dashboard is forced to use glance endpoint v1, even though i've put the correct configuration in the horizon local settings

OPENSTACK_API_VERSIONS = {
      "data-processing": 1.1,
      "identity": 3,
      "image": 2,
      "volume": 2,
}

Meanwhile the CLI command run correctly because i can force it to use the v2 service endpoint with OS_IMAGE_API_VERSION environment variable.

So, please, someone could help me, show me the light? What mistakes did i do? or is the any configuration that i left out?

Thanks

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-09-19 01:47:18 -0500

michaelf gravatar image

I had the same problem, to fix it i found that in .../openstack-dashboard/openstack_dashboard/api/glance.py the default version of 'def glanceclient(request, version='1')' is 1 i changed it to 'def glanceclient(request, version='2')' rebooted apache2 "service apache2 reload" and it worked

edit flag offensive delete link more

Comments

This solved a similar issue for me.

Openstackuser2013 gravatar imageOpenstackuser2013 ( 2018-08-31 07:02:13 -0500 )edit
0

answered 2017-02-24 09:00:26 -0500

yoba gravatar image

It seems that there's a little error on the OpenStack official documentation (https://docs.openstack.org/mitaka/install-guide-rdo/horizon-install.html#install-and-configure-components (https://docs.openstack.org/mitaka/ins...)) for Mitaka. Using API version 2 for image is implemented from the Newton version. So you have to change the configuration in the local settings of the dashboard (/etc/openstack-dashboard/local_settings) and make the use of the Openstack API version 1 for image the restart httpd service.

OPENSTACK_API_VERSIONS = { "identity": 3, "image": 1, "volume": 2, }

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-08-18 12:16:42 -0500

Seen: 2,063 times

Last updated: Feb 24 '17