Ask Your Question
0

Installing Openstack Mitaka RDO On CentOS 7 a remote server with public IP using only SSH

asked 2016-08-16 03:43:26 -0500

Joe2006 gravatar image

Hello, I tried to install Openstack following the steps on RDO And I got it installed without any errors but I can not access the dashboard!

I am testing Open stack on my dedicated server with dual E-5 processor and 32GB of RAM and 480GB SSD drive but what happened that when the installation Was finished it looks like it’s using 127.0.0.1 as host and as main IP not my Real IP so when I try to access the dashboard through MyIP/dashboard I get 404 page not found error!

I am accessing the server remotely through SSH only.

The server has a publice IP and I've edited the ifcfg for my network interface And made sure that the server's IP is set correctly, also I did set BOOTPROTO=”static”

The only 127.0.0.1 that I can see in my ifcfg file is DNS1=127.0.0.1 What do I need to change to not get this :

Applying 127.0.0.1_prescript.pp

127.0.0.1_prescript.pp: [ DONE ] Applying 127.0.0.1_amqp.pp Applying

127.0.0.1_mariadb.pp

127.0.0.1_amqp.pp: [ DONE ]

127.0.0.1_mariadb.pp: [ DONE ] Applying 127.0.0.1_apache.pp

127.0.0.1_apache.pp: [ DONE ] Applying 127.0.0.1_keystone.pp Applying 127.0.0.1_glance.pp Applying 127.0.0.1_cinder.pp

127.0.0.1_keystone.pp: [ DONE ]

127.0.0.1_glance.pp: [ DONE ]

127.0.0.1_cinder.pp: [ DONE ]

Pleases help me fix this Thanks

edit retag flag offensive close merge delete

Comments

1

You better use Network Manager to assign static IP to server acceptable for your LAN and internet enabled. Login to server via ssh and run packstack ( with NM enabled ) , after install commited disable NM and switch to network service to enable br-ex and basic interface (say eno3) as OVS

dbaxps gravatar imagedbaxps ( 2016-08-16 12:00:59 -0500 )edit
1

port for br-ex. If GUI is not available set up static IP via ifgcfg files with same requirements as told above via network service.

dbaxps gravatar imagedbaxps ( 2016-08-16 12:01:37 -0500 )edit

Thanks a lot for the advice ... I know how to set a static IP using NM but I am not sure of the Next steps! I am new to open stack so I will need some details regarding how to switch to network service to enable br-ex and basic interface and OVS Thanks

Joe2006 gravatar imageJoe2006 ( 2016-08-16 13:04:38 -0500 )edit

Well, just commit packtack with normal IP. Tomorrow I will explain the rest ( 9:30 p.m. local time ). Don't worry packstack installs restart able services. Shutdown is 100% safe. Services will be up at box start up

dbaxps gravatar imagedbaxps ( 2016-08-16 13:39:32 -0500 )edit

Thanks again, I will start the installation soon and I will wait for your next comment

Joe2006 gravatar imageJoe2006 ( 2016-08-16 13:46:57 -0500 )edit

1 answer

Sort by » oldest newest most voted
2

answered 2016-08-17 00:11:23 -0500

dbaxps gravatar image

updated 2016-08-17 17:21:38 -0500

Setting up BR-EX and OVS port . Say your IP was 192.169.142.127 and basic interface eth0 for instance
Create files under /etc/sysconfig/network-scripts

# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="192.169.142.127"
NETMASK="255.255.255.0"
DNS1="83.221.202.254"
BROADCAST="192.169.142.255"
GATEWAY="192.169.142.1"
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

# cat ifcfg-eth0
DEVICE="eth0"
ONBOOT="yes"
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex
NM_CONTROLLED=no
IPV6INIT=no

Run to switch to network service

#!/bin/bash -x
chkconfig network on
systemctl stop NetworkManager
systemctl disable NetworkManager
service network restart

Or reboot node
For further reading see http://dbaxps.blogspot.com/2015/10/rd...
image description

edit flag offensive delete link more

Comments

Thanks a lot but now when I run openstack-status I can see that many openstack service are disabled:

openstack-nova-network: inactive (disabled on boot)

openstack-nova-console: inactive (disabled on boot)

openstack-keystone: inactive (disabled on boot)

Joe2006 gravatar imageJoe2006 ( 2016-08-17 14:48:57 -0500 )edit
1

That is expected for RDO Mitaka. Legacy Nova Networking deprecated since Havana
Keystone functionality encapsulated in httpd. Regarding third just cannot remind this one at all
Can you access dashboard VNC console ?

dbaxps gravatar imagedbaxps ( 2016-08-17 16:16:27 -0500 )edit

Switching to br-ex is absolutely unrelated with disabling services by packstack RDO installer.

dbaxps gravatar imagedbaxps ( 2016-08-17 16:19:35 -0500 )edit

As usual thanks for your help! I know br-ex is not related I just wanted to make sure that the installation Is good an complete. now I can access Openstack dashboard normally is there a test that can confirm that openstack is installed and running normally? Thanks

Joe2006 gravatar imageJoe2006 ( 2016-08-17 16:48:38 -0500 )edit
1

Yes, just launch cloud VM with floating IP on your office LAN && ssh using created ssh keypair into VM
From within your cloud VM make sure ping msn.com either links ( text web browser ) works as expected.

dbaxps gravatar imagedbaxps ( 2016-08-17 16:58:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-08-16 03:43:26 -0500

Seen: 599 times

Last updated: Aug 17 '16