Ask Your Question
0

Installing Openstack Mitaka RDO On CentOS 7 server with a public through SSH only!

asked 2016-08-16 03:32:00 -0500

Joe2006 gravatar image

Hello, I tried to install Openstack following the steps on RDO And I got it installed without any errors but I can not access the dashboard!

I am testing Open stack on my dedicated server with dual E-5 processor and 32GB of RAM and 480GB SSD drive but what happened that when the installation Was finished it looks like it’s using 127.0.0.1as host and as main IP not my Real IP so when I try to access the dashboard through http://MyIP/dashboard I get 404 page not found error!

I am accessing the server remotely through SSH only.

The server has a publice IP and I've edited the ifcfg for my network interface And made sure that the server's IP is set correctly, also I did set BOOTPROTO=”static”

The only 127.0.0.1 that I can see in my ifcfg file is DNS1=127.0.0.1 What do I need to change to not get this :

Applying 127.0.0.1_prescript.pp

127.0.0.1_prescript.pp: [ DONE ] Applying 127.0.0.1_amqp.pp Applying

127.0.0.1_mariadb.pp

127.0.0.1_amqp.pp: [ DONE ]

127.0.0.1_mariadb.pp: [ DONE ] Applying 127.0.0.1_apache.pp

127.0.0.1_apache.pp: [ DONE ] Applying 127.0.0.1_keystone.pp Applying 127.0.0.1_glance.pp Applying 127.0.0.1_cinder.pp

127.0.0.1_keystone.pp: [ DONE ]

127.0.0.1_glance.pp: [ DONE ]

127.0.0.1_cinder.pp: [ DONE ]

Pleases help me fix this Thanks

edit retag flag offensive close merge delete

Comments

1

Hi, I assume you've installed openstack by packstack. Please check keystone & dashboard services by executing openstack-status.

Praveen N gravatar imagePraveen N ( 2016-08-17 09:01:01 -0500 )edit

Hi, thanks fro the response, I run openstack-status I can see that many openstack service are disabled:

openstack-nova-network: inactive (disabled on boot)

openstack-nova-console: inactive (disabled on boot)

openstack-keystone: inactive (disabled on boot)

Joe2006 gravatar imageJoe2006 ( 2016-08-17 14:38:31 -0500 )edit

Hi, I can access the dashboard I even managed to create an instance. I was told that these services have been replaced in Mitaka and this is Why they are disabled but yet I still can access the dashboard normally And create instances too...

Joe2006 gravatar imageJoe2006 ( 2016-08-18 01:32:10 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2016-08-17 23:14:19 -0500

Praveen N gravatar image

To access the dashboard, run

systemctl stop openstack-keystone.service

systemctl stop httpd.service

Then start keystone alone:

systemctl start openstack-keystone.service

Check the status for both keystone & httpd service. Then try to access dashboard.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-08-16 03:32:00 -0500

Seen: 119 times

Last updated: Aug 16 '16