Ask Your Question
2

Glance image-create returns HTTPInternalServerError (HTTP 500) [closed]

asked 2013-12-27 11:12:49 -0500

loren.clint gravatar image

updated 2013-12-27 12:40:11 -0500

smaffulli gravatar image

Finished the glance install and setup on Ubuntu 12.04 Openstack following the install guide and when I run the following command I get the following error:

glance image-create --name="CirrOS 0.3.1" --disk-format=qcow2   --container-format=bare --is-public=true < cirros-0.3.1-x86_64-disk.img
Request returned failure status.
HTTPInternalServerError (HTTP 500)

I checked the /var/log/glance/api.log and shows the following errors.

Stderr: '/bin/sh: 1: collie: not found\n' Disabling add method.
2013-12-27 10:27:55.427 3567 WARNING glance.store.base [-] Failed to configure store correctly: Store cinder could not be configured correctly. Reason: Cinder storage requi$
2013-12-27 10:27:55.439 3567 WARNING glance.api.v2.images [-] Could not find schema properties file schema-image.json. Continuing without custom properties

Checking the mysql database the after syncing the database the tables for glance are still empty.

Here is my /etc/glance/glance-api.conf file.

edit retag flag offensive reopen delete

Closed for the following reason the question is answered, right answer was accepted by Closed for the following reason "the question is answered, right answer was accepted" by dheeru
close date 2014-02-07 00:37:56.400722

Comments

You server is getting into some issue. Are you configuring cinder as back-end store ?

dheeru ( 2013-12-27 11:34:44 -0500 )edit

I haven't even reached the storage setup stage this error is on the image service stage. The install document suggest using CirrOS 3.1 as a test to verify the image service is installed and running. http://docs.openstack.org/havana/install-guide/install/apt/content/glance-verify.html%3C/p%3E (http://docs.openstack.org/havana/install-guide/install/apt/content/glance-verify.html)

loren.clint ( 2013-12-27 11:46:54 -0500 )edit

ok. What is your email id. I will send you the sample configuration which I have over email. It should work for you

dheeru ( 2013-12-27 12:07:34 -0500 )edit
<p>lclint@pearlnet.com Thanks for the help

loren.clint ( 2013-12-27 12:09:42 -0500 )edit

just sent an email. Please ensure that you put the appropriate passwords and user name If you need help do let me know.

dheeru ( 2013-12-27 12:17:40 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-01-26 20:58:57 -0500

ballerz23 gravatar image

Ok I was able to solve it. It was a silly mistake on my part. When I granted privileges on glance table, I forgot to change the password 'GLANCE DBPASS'. It worked fine when I changed that and synced the db again.

edit flag offensive delete publish link more
0

answered 2014-02-06 10:47:39 -0500

Just adding to this. I managed to get rid of the error 500 by commenting out all of the unused storage options. Not sure why the package leaves them in by default.

edit flag offensive delete publish link more

Comments

i am getting the same error...can you please explain me the changes i need to do...which lines i need to comments?? do i need to add [paste_deploy] flavor=keystone in glance-api-paste.ini???please help

pratik ( 2014-03-16 14:10:17 -0500 )edit
0

answered 2013-12-27 18:35:18 -0500

SamYaple gravatar image

Add this to your glance-api.conf at the bottom. This assume you are using keystone like the guide says. Also check your glance-api-paste.ini file!

[paste_deploy]
flavor=keystone
edit flag offensive delete publish link more

Question Tools

Follow
1 follower

Stats

Asked: 2013-12-27 11:12:49 -0500

Seen: 1,519 times

Last updated: Feb 06