"Parameter outiface failed on Firewall" during installation of openstack rdo on centos 7 [closed]

asked 2016-08-14 10:47:55 -0500

nevyan gravatar image

updated 2016-08-18 14:38:41 -0500

rbowen gravatar image
ERROR : Error appeared during Puppet run: 10.254.254.100_provision_bridge.pp
Error: Parameter outiface failed on Firewall[000 forward out]: Invalid value "". Valid values match /^!?\s?[a-zA-Z0-9\-\._\+\:]+$/. at /var/tmp/packstack/9820719af3a44c3cbc7ffc4c4cef1bfa/manifests/10.254.254.100_provision_bridge.pp:54
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2017-08-22 09:32:01.635924

Comments

Post :-
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS= ?
Check does https://bugs.launchpad.net/packstack/... apply to your issue ?

dbaxps gravatar imagedbaxps ( 2016-08-15 02:05:09 -0500 )edit

checked ..DRIVERS=openvswitch, after some updates, the error changed to:

ERROR : Error appeared during Puppet run: 10.254.254.100_controller.pp
Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Could not find declared class ::packstack::prereqs at /var/tmp/packstack/5812527ff
nevyan gravatar imagenevyan ( 2016-08-17 03:23:20 -0500 )edit

How you set up RDO repos ( which realease )?

dbaxps gravatar imagedbaxps ( 2016-08-17 07:21:34 -0500 )edit

What method are you using that leads to this error? ie, what command line did you run to get here?

rbowen gravatar imagerbowen ( 2016-08-18 14:38:12 -0500 )edit

sudo packstack --answer-file=.answers.cfg

nevyan gravatar imagenevyan ( 2016-08-19 00:12:17 -0500 )edit