Ask Your Question
0

triple0 localhost ssh fail

asked 2016-08-11 17:18:37 -0500

tictoc gravatar image

Seems it's a common fail but I have not found anything that get's me past the error

TASK [tripleo/undercloud : Create undercloud configuration] ***** task path: /home/stack/tripleo-quickstart/roles/tripleo/undercloud/tasks/create-scripts.yml:3 Thursday 11 August 2016 16:16:54 -0600 (0:00:00.101) 0:00:28.354 ** fatal: [undercloud]: FAILED! => {"changed": false, "failed": true, "msg": "SSH Error: data could not be sent to the remote host. Make sure this host can be reached over ssh"}

PLAY RECAP *********************** localhost : ok=63 changed=16 unreachable=0 failed=0 undercloud : ok=1 changed=0 unreachable=0 failed=1

I can manually ssh into the undercloud vm as stack or root so it's working there

Anyone?

edit retag flag offensive close merge delete

Comments

If you export VIRTHOST=127.0.0.1 would you be able to run as user running quickstart.sh
$ ssh root@$VIRTHOST uname -a
with out password promt

dbaxps gravatar imagedbaxps ( 2016-08-13 23:17:33 -0500 )edit

Tested this and same error plus the script is meant to be run as stack.

tictoc gravatar imagetictoc ( 2016-08-14 05:24:20 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-08-13 03:09:32 -0500

dbaxps gravatar image

updated 2016-08-15 03:21:11 -0500

UPDATE 08/15/16
Per https://www.redhat.com/archives/rdo-l...

My thinking is the method would take image definitions in a yaml format
similar to how ansible-role-tripleo-image-build works, and we can just
ship a bunch of different yaml files for all the different image
scenarios people might want. e.g.

/usr/share/tripleo-images/centos-7-x86_64-mitaka-cbs.yaml
/usr/share/tripleo-images/centos-7-x86_64-mitaka-trunk.yaml
/usr/share/tripleo-images/centos-7-x86_64-trunk.yaml

Due to VENV is always using mitaka-trunk, rather then stable repo and succeeds with

 $  openstack overcloud image build --all

END UPDATE
In meantime upstream links :-
http://docs.openstack.org/developer/t...
http://docs.openstack.org/developer/t...
look just fine and Google's cache as well.
Double check following :-

Edit /etc/ssh/sshd_conf and add another MAC algorithm: MACs hmac-sha1
Then, restart the service with systemctl restart sshd

Following link may be usefull installing on localhost :-
https://www.rdoproject.org/tripleo/oo...

edit flag offensive delete link more
0

answered 2016-08-13 01:50:07 -0500

I would guess python-tripleoclient is installed , if it is not installed then install it and follow standard instructions
http://docs.openstack.org/developer/t...
either see http://lxer.com/module/newswire/view/... to avoid issue with Network Isolation silently skipped in upstream instructions .

edit flag offensive delete link more

Comments

the delorean path seems interesting and will test it out on a clean build later today. Also looking at testing the thumb drive build out and see how that goes. What is the differences in the delorean build and the quick-start one?

tictoc gravatar imagetictoc ( 2016-08-14 05:27:22 -0500 )edit

Tripleo QuickStart seems to make some smart choice of point in same trunk , but different from mitaka/current
Most probably it takes the most recent branch current/passed-ci. Approach suggested in posting to lxer.com principally differs from QuickStart. The instack-virt-setup is used.

andrew.shvartz gravatar imageandrew.shvartz ( 2016-08-14 08:41:08 -0500 )edit

This way everything works as well , but versus QS you clearly see every step during the way to deploy overcloud (virtual env). Moreover Pacemaker CLI appears to work ( which comes up dead in QiuckStart), but HA Cluster been built is not quite stable as in case of QS.

andrew.shvartz gravatar imageandrew.shvartz ( 2016-08-14 08:46:52 -0500 )edit

As far as to my knowledge RH is working on cold backup/restore for virtual version of QuickStart.
Question with replacing failed Controller in HA (PCS/Corosync) Cluster stays in BZ as RFE with no feed backs so far. TripleO Mitaka/Stable deployments on bare metal are experiencing hard issues

andrew.shvartz gravatar imageandrew.shvartz ( 2016-08-14 08:57:32 -0500 )edit

seems the baremetal install and virtual machines do not work to well together ... might have to go the Kolla route since it supports both baremetal and virtual machines

tictoc gravatar imagetictoc ( 2016-08-14 19:29:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-08-11 17:18:37 -0500

Seen: 361 times

Last updated: Aug 15 '16