Ask Your Question
0

External network doesn't have connection with my physical router

asked 2016-08-10 09:37:18 -0600

Diego García gravatar image

Hi everybody. I have a problem with the external network and the ip floatings. I have installed Openstack (RDO packstack) in three nodes (Controller, network and compute) on Proxmox. Each node is a VM with CentOs 7.

The Proxmox server (192.168.1.99) has a NIC connected with the physical router (192.168.1.1)

Network node have 2 vNICs:

  • ens18: 192.168.1.2 (physical network) Ping to router works fine
  • ens19: 10.0.0.10 (Proxmox internal network)

Compute node have 2 vNICs:

  • ens18: 10.0.0.20
  • ens19: 192.168.1.4 Ping to router works fine

Controller node has a vNIC:

  • ens18: 10.0.0.30

I have created a external network and a subnet with a floating-ip pool (range: 192.168.1.100,192.168.1.200). And a internal network (10.0.10.0/24) where i launch my instances. But when i attach a floating-ip to an instance (for example: 192.168.1.101) my physical router don't see this IP. Ping from compute node to 192.168.1.101 doesn't works.

How can I configure my environment for my physical router can have a direct connection to the external network? Are all my nodes must be connected with my physical router?

Thank you very much and excuse me for my English. My best regards

edit retag flag offensive close merge delete

Comments

Which command did you run in order to create the external network? Please note that the GW should be your real GW (in this case your physical router).

Antonio G. gravatar imageAntonio G. ( 2016-08-10 10:38:35 -0600 )edit

Hi Antonio. I used this commands: http://docs.openstack.org/mitaka/install-guide-ubuntu/launch-instance-networks-provider.html (http://docs.openstack.org/mitaka/inst...) and then i create other external network in horizon (as a admin user) but neither it worked. The GW that I put was 192.168.1.1 and 192.168.1.0/24 as network CIDR

Diego García gravatar imageDiego García ( 2016-08-11 01:46:26 -0600 )edit

2 answers

Sort by » oldest newest most voted
2

answered 2016-08-10 12:33:15 -0600

dbaxps gravatar image

updated 2016-08-10 12:41:22 -0600

Here goes idea how to achieve RDO deployment on VMs running on KVM Hypervisor Fedora 23 work as follows
RDO Mitaka Virtual Deployment having real physical network as External
I have never heard what Proxmox is, but bare metal VIRTHOST should have linux bridge on External physical network, VM running Network Node should have VNIC as on first screen shot ( see link above). Virtual external network should be created via flat external network provider matching real physical network Sample of VIRTHOST bridge setup :-

[root@fedora23wks network-scripts]# cat ifcfg-br0
DEVICE=br0
TYPE=Bridge
BOOTPROTO=static
DNS1=192.168.1.1
DNS2=83.221.202.254
GATEWAY=192.168.1.1
IPADDR=192.168.1.57
NETMASK=255.255.255.0
ONBOOT=yes

[root@fedora23wks network-scripts]# cat ifcfg-enp3s0
DEVICE=enp3s0
HWADDR=78:24:af:43:1b:53
ONBOOT=yes
TYPE=Ethernet
IPV6INIT=no
USERCTL=no
BRIDGE=br0

***************************
Then run script
***************************
#!/bin/bash -x
chkconfig network on
systemctl stop NetworkManager
systemctl disable NetworkManager
service network restart

Creating external network via flat external network provider on Controller matching CIDR of Office LAN 192.168.1.1 is IP of external physical router device.

image description
image description

edit flag offensive delete link more
0

answered 2016-08-12 01:00:12 -0600

Diego García gravatar image

updated 2016-09-01 09:36:03 -0600

Thank you. Finally I could fix it. I installed RDO openstack again according to your advice and this link: http://www.ksingh.co.in/blog/2015/07/12/deploying-openstack-kilo-using-rdo/ (http://www.ksingh.co.in/blog/2015/07/...)

See you soon ;)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-08-10 09:33:16 -0600

Seen: 310 times

Last updated: Sep 01 '16