Ask Your Question

error installing openstack using packstack

asked 2016-08-06 19:27:46 -0600

alireza gravatar image

hi everyone i have installed centos 7 (server GUI) in vmware i want to install openstack mitaka using rdo packstack

i did : $ sudo systemctl disable firewalld $ sudo systemctl stop firewalld $ sudo systemctl disable NetworkManager $ sudo systemctl stop NetworkManager $ sudo systemctl enable network $ sudo systemctl start network

$ sudo yum install -y centos-release-openstack-mitaka $ sudo yum update -y $ sudo yum install -y openstack-packstack

then : $ packstack --allinone

but i got this error : [ ERROR ]
Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: Error: Could not prefetch cinder_type provider 'openstack': Command: 'openstack ["volume type", "list", "--quiet", "--format", "csv", "--long"]' has been running for more then 20 seconds!

i've got enough resources and internet speed

so what shall i do now ?


edit retag flag offensive close merge delete


Hi, Please share the logs once after you faced that error. Also check for the value CONFIG_CINDER_BACKEND in the packstack answer file. Regards

Praveen N gravatar imagePraveen N ( 2016-08-06 20:51:18 -0600 )edit

In the packstack answer file, leave the parameter CONFIG_CINDER_BACKEND to blank removing lvm. Then run that answer file. Also this seems like a bug.

Praveen N gravatar imagePraveen N ( 2016-08-06 21:07:13 -0600 )edit


unfortunately it didn't work thanks for your answer

alireza gravatar imagealireza ( 2016-08-08 18:57:11 -0600 )edit

3 answers

Sort by ยป oldest newest most voted

answered 2016-08-08 14:12:12 -0600

dashpartha gravatar image

I know for begineers its bit tough. follow this video & you will be good to go.. (

Thanks Partha

edit flag offensive delete link more

answered 2016-08-07 01:05:31 -0600

dbaxps gravatar image

updated 2016-08-07 10:53:46 -0600

UPDATE 19:51 MSK 08/07/16
Try before install :-

 pip install osc-lib

Sounds like keystone V2 now is affected in the same way as keystone V3 was since release RDO MItaka.

Run packstack --gen-answer-file=answer.txt and check for default keystone version
My concern is it still V2 either they switched to V3. My answer itself follows bellow.

See :-
I would try back port patch and try with V2 in case of failure, option been tested was to switch to V3 via generated answer file and manage as in :-
If instructions above appears to be hard to reproduce I am posting ugly hack bellow which worked for me nicely.

 Another option generate answer file and run packstack --answer-file=./generated-answer.txt. Check status of cinder services after crash, if they are up and running, then disable cinder set up  via answer file and rerun.  Both ways worked for me with Keystone V3 been set up in generated-answer.txt
edit flag offensive delete link more


packstack --answer-file=./generated-answer.txt showed the error again then i made the keystone version to 3 (was v2.0 by default) and showed many errors thanks for your answer

alireza gravatar imagealireza ( 2016-08-08 19:00:48 -0600 )edit

Keystone API V3 requires back porting patches see :-

dbaxps gravatar imagedbaxps ( 2016-08-09 04:06:26 -0600 )edit

Back port patches as advised for V3

dbaxps gravatar imagedbaxps ( 2016-08-09 04:06:51 -0600 )edit

Also please provide all stack trace . Does it complain failure to import osc_lib at the end

dbaxps gravatar imagedbaxps ( 2016-08-09 04:34:17 -0600 )edit

answered 2016-08-10 23:15:33 -0600

Would you mind trying RDO? This is the current repo:

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-08-06 19:27:46 -0600

Seen: 2,019 times

Last updated: Aug 10 '16