Ask Your Question
0

Amphora image multi nic support

asked 2016-08-04 08:25:44 -0500

Selvakumar gravatar image

Octavia uses amphora-x64-haproxy image to boot for load balancing, as you know currently it has single NIC with IP assigned with octavia management network . If we want to test the load balancing we would like to have another NIC assigned with private tenant subnet.

I logged in to the amphora image and could not see any eth1 interface . Is there any specific reason to have single NIC ?

Thanks Selvakumar

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-11-17 11:31:34 -0500

johnsom gravatar image

Also note, the tenant networks are automatically plugged when you add members. When logging into the amphora, you need to look in the network namespace to see the "data path" network interfaces: "ip netns exec amphora-haproxy ip link"

edit flag offensive delete link more
0

answered 2016-11-11 22:00:15 -0500

diltram gravatar image

Did you completely configure that load balancer? You need to assign pool, members, and the listeners to LB to really use it. Also, you need to provide logs from o-cw to verify what is going on there

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-08-04 08:25:44 -0500

Seen: 115 times

Last updated: Nov 11 '16