Ask Your Question
0

swift can't verify Errno 111 Connection refused [closed]

asked 2013-12-26 18:57:25 -0500

jothep gravatar image

updated 2014-01-06 14:42:19 -0500

smaffulli gravatar image

when I installed swift,I find that it can't verify like that:

 root@objproxy:/etc/swift# swift -V 2.0 -A $OS_AUTH_URL -U admin:admin -K admin123 stat
 [Errno 111] Connection refused

I find in controller's keystone log, but nothing. If I use wrong id&password,the log will show a warning.but use this nothing but Errno 111.

I had reinstalled swift proxy and storage, but it still can't work. By the install guide, I can't see anywhere of keystone add user and add swift to mysql. I had add keystone user swift by manual but do nothing to mysql. Did I missed something?

I catch keystone user-list tenant-list role-list from keystone server

root@controller:~# keystone service-list
+----------------------------------+----------+--------------+---------------------------+
|                id                |   name   |     type     |        description        |
+----------------------------------+----------+--------------+---------------------------+
| 0061aafc4324493e875850f7c5e4cfb2 |  cinder  |    volume    |   Cinder Volume Service   |
| 983301d0e10b4031924da992df572bb1 |  cinder  |   volumev2   |  Cinder Volume Service V2 |
| b36c4ff4f17b4d2695bfd1aeb7b54c76 |  glance  |    image     |    Glance Image Service   |
| f3bc12b6aa544287b8f480babff96cc1 | keystone |   identity   | Keystone Identity Service |
| 5579210582824c299a0d3be2b626d363 |   nova   |   compute    |    Nova Compute Service   |
| e09d50424c3d49359fedad14485ee7a9 |  swift   | object-store |       Swift Service       |
+----------------------------------+----------+--------------+---------------------------+
root@controller:~# keystone user-list
+----------------------------------+--------+---------+----------------+
|                id                |  name  | enabled |     email      |
+----------------------------------+--------+---------+----------------+
| 0a881fc7092f46bb924b02814e026c77 | admin  |   True  | zhux@12366.net |
| a67d6cdf13674741a6c722ba35baeb16 | cinder |   True  | zhux@12366.net |
| 0a8d22e04c6149f4b77caced7bcfb988 | glance |   True  | zhux@12366.net |
| 51b697de5766415a97e3b8d8cb80e031 |  nova  |   True  | zhux@12366.net |
| 0fa5116f6d0e4d86802a33b52572a175 | swift  |   True  |                |
| c2e2da04bea44d148c94b010566ec1eb |  test  |   True  |                |
+----------------------------------+--------+---------+----------------+
root@controller:~# keystone tenant-list
+----------------------------------+---------+---------+
|                id                |   name  | enabled |
+----------------------------------+---------+---------+
| a035b675a2bc4819b0b12a7cce48a7ac |  admin  |   True  |
| 2ab0f37031124806b65bef10e04427cf | service |   True  |
+----------------------------------+---------+---------+

proxy-init.conf

[DEFAULT]
bind_port = 8080
user = swift

[pipeline:main]
pipeline = healthcheck cache authtoken keystoneauth proxy-server

[app:proxy-server]
use = egg:swift#proxy
allow_account_management = true
account_autocreate = true

[filter:keystoneauth]
#paste.filter_factory = keystone.middleware.swift_auth:filter_factory
use = egg:swift#keystoneauth
operator_roles = Member,admin,swiftoperator

#[filter:keystone]
#paste.filter_factory = keystone.middleware.swift_auth:filter_factory
#operator_roles = Member,admin

[filter:authtoken]
#paste.filter_factory = keystone.middleware.auth_token:filter_factory
paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory
# Delaying the auth decision is required to support token-less
# usage for anonymous referrers ('.r:*').
delay_auth_decision = true
# cache directory for signing certificate
signing_dir = /home/swift/keystone-signing
# auth_* settings refer to the Keystone server
service_port = 5000
service_host = 192.168.0.10
auth_protocol = http
auth_host = 192.168.0.10

auth_protocol = http
auth_host = 192.168.0.10
auth_port = 35357
# the same admin_token as provided in keystone.conf
admin_token = 88fb41585ef65ed1fd49
# the service tenant and swift userid and password created in Keystone
admin_tenant_name = service
#auth_token = 88fb41585ef65ed1fd49
admin_user = swift
admin_password = swift123

[filter:cache]
use = egg:swift#memcache

[filter:catch_errors]
use = egg:swift#catch_errors

[filter:healthcheck]
use = egg:swift#healthcheck
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by dheeru
close date 2014-01-15 01:57:34.552772

Comments

@jothep did u add same credentials in proxy server configuration & changed the middleware to listen/understand keystone?

koolhead17 gravatar imagekoolhead17 ( 2013-12-27 01:32:01 -0500 )edit

I had installed keystone (and python-keystone pythone-keystone-client,but that's must installed)on proxy server.But I had not to do anysetting of it.

jothep gravatar imagejothep ( 2013-12-27 03:23:18 -0500 )edit

2 answers

Sort by » oldest newest most voted
1

answered 2013-12-26 22:56:25 -0500

dheeru gravatar image
  1. Verify that keystone is working fine.
  2. Can you share the keystone user-list, keystone tenant-list and keystone role-list, keystone endpoint-list
  3. What are your environment variables ? What is value set for OS_AUTH_URL ?
edit flag offensive delete link more

Comments

1.2.keystone server(named controller)is working fine.I can logon to check my swift server:Then I'll put it below 3. root@objproxy:/var/log# echo $OS_AUTH_URL http://controller:5000/v2.0%3C/p%3E (http://controller:5000/v2.0)

jothep gravatar imagejothep ( 2013-12-27 03:18:30 -0500 )edit

are you able to fix it? I hope your configuration inside swift proxy conf is same as the users you created via keystone.

koolhead17 gravatar imagekoolhead17 ( 2014-01-02 00:01:44 -0500 )edit
1

answered 2014-01-08 19:58:22 -0500

jothep gravatar image

updated 2014-01-08 20:00:39 -0500

I was finally solved it.The most important thing is to create right keystone endpoint and swift user/service.

keystone endpoint-create --region regionOne --service_id service id 
--publicurl http://192.168.0.13:8080/v1/AUTH_admintenant 
--adminurl http://192.168.0.13:8080 
--internalurl http://192.168.0.13:8080/v1/AUTH_admintenant

It can't be find in the installguide.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-26 18:57:25 -0500

Seen: 1,689 times

Last updated: Jan 08 '14