Ask Your Question
0

Mitaka Glance 503 Service Unavailable: The server is currently unavailable. Please try again at a later time. (HTTP 503)

asked 2016-07-31 05:50:41 -0500

Irshad gravatar image
 I followed the exact same steps as per openstack mitaka documentation for centos7 and pretty sure that i didnt misconfigure anything. Infact i tried to configure from scratch in a new VM  and got the same error. It looks like a bug but am unable to trace anything. Any help would be much appreciated. I've added few new lines between logs for better viewing in browser.

Below is my config file

# cat /etc/glance/glance-api.conf
[database]

connection = mysql+pymysql://glance:glance@controller/glance

[glance_store]

stores = file,http

default_store = file

filesystem_store_datadir = /var/lib/glance/images/


[keystone_authtoken]

auth_uri = http://controller:5000

auth_url = http://controller:35357

memcached_servers = controller:11211

auth_type = password

project_domain_name = default

user_domain_name = default

project_name = service

username = glance

password = glance


[paste_deploy]

flavor = keystone



# cat /etc/glance/glance-registry.conf 
[database]

connection = mysql+pymysql://glance:glance@controller/glance

[keystone_authtoken]

auth_uri = http://controller:5000

auth_url = http://controller:35357

memcached_servers = controller:11211

auth_type = password

project_domain_name = default

user_domain_name = default

project_name = service

username = glance

password = glance

[paste_deploy]

flavor = keystone

# cat admin-openrc

export OS_PROJECT_DOMAIN_NAME=default

export OS_USER_DOMAIN_NAME=default

export OS_PROJECT_NAME=admin

export OS_USERNAME=admin

export OS_PASSWORD=admin

export OS_AUTH_URL=http://controller:35357/v3

export OS_IDENTITY_API_VERSION=3

export OS_IMAGE_API_VERSION=2


# openstack image create "cirros" --file cirros-0.3.4-x86_64-disk.img --disk-format qcow2 --container-format bare --public -vvv

START with options: ['image', 'create', 'cirros', '--file', 'cirros-0.3.4-x86_64-disk.img', '--disk-format', 'qcow2', '--container-format', 'bare', '--public', '-vvv']
options: Namespace(access_token_endpoint='', auth_type='', auth_url='http://controller:35357/v3', cacert='', client_id='', client_secret='***', cloud='', debug=False, default_domain='default', deferred_help=False, domain_id='', domain_name='', endpoint='', identity_provider='', insecure=None, interface='', log_file=None, os_compute_api_version='', os_identity_api_version='3', os_image_api_version='2', os_network_api_version='', os_object_api_version='', os_project_id=None, os_project_name=None, os_volume_api_version='', password='***', profile=None, project_domain_id='', project_domain_name='default', project_id='', project_name='admin', protocol='', region_name='', scope='', timing=False, token='***', trust_id='', url='', user_domain_id='', user_domain_name='default', user_id='', username='admin', verbose_level=4, verify=None)
defaults: {u'auth_type': 'password', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'api_timeout': None, u'baremetal_api_version': u'1', u'image_api_version': u'2', 'cacert': None, u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': u'1', u'interface': None, u'network_api_version': u'2', u'image_format': u'qcow2', u'key_manager_api_version': u'v1', u'metering_api_version': u'2', 'verify': True, u'identity_api_version': u'2.0', u'volume_api_version': u'2', 'cert': None, u'secgroup_source': u'neutron', u'container_api_version': u'1', u'dns_api_version': u'2', u'object_store_api_version': u'1', u'disable_vendor_agent': {}}
cloud cfg: {'auth_type': 'password', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'cacert': None, u'network_api_version': u'2', u'image_format': u'qcow2', u'image_api_version': '2', 'verify': True, u'dns_api_version': u'2', u'object_store_api_version': u'1', 'verbose_level': 4, 'region_name': '', 'api_timeout': None, u'baremetal_api_version': u'1', 'auth': {'username': 'admin', 'project_name': 'admin', 'user_domain_name': 'default', 'auth_url': 'http://controller:35357/v3', 'password': '***', 'project_domain_name': 'default'}, 'default_domain': 'default', u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': u'1', 'timing': False, u'key_manager_api_version': u'v1', u'metering_api_version': u'2', 'deferred_help': False, u'identity_api_version': '3', u'volume_api_version': u'2', 'cert': None, u'secgroup_source': u'neutron', u'container_api_version': u'1', u'interface': None, u'disable_vendor_agent': {}}


compute API version 2, cmd group openstack.compute.v2
network API version ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2016-07-31 13:27:52 -0500

updated 2016-07-31 13:44:52 -0500

An incorrect glance user password will cause this error. Check /var/log/glance/api.log for cause of error. Update the user password with openstack user set --password glance glance

edit flag offensive delete link more

Comments

Thanks for your response. I tried to reset it but it didnt fix the issue. Am getting the same error as earlier. Below is the error from keystone

WARNING keystone.common.wsgi [req-3c519dba-00d1-47a3-8014-d656f1e38641 - - - - -] Authorization failed. The request you have made requires authentication.

Irshad gravatar imageIrshad ( 2016-07-31 23:48:03 -0500 )edit

Apparently am able to issue an admin token from keystone even though am getting a warning as above. # unset OS_TOKEN OS_URL # openstack --os-auth-url http://controller:35357/v3 --os-project-domain-name default --os-user-domain-name default --os-project-name admin --os-username admin token issue

Irshad gravatar imageIrshad ( 2016-08-01 00:17:27 -0500 )edit

Try reissuing the database grant privileges for the glance user using the password 'glance'. Also confirm the glance user has the admin role in the service project using openstack role assignment list --names.

barry.davis gravatar imagebarry.davis ( 2016-08-01 06:09:49 -0500 )edit

I ran into this problem and I set the wrong password and used openstack user set --password [new glance password] glance and it fixed my issue.

rrottach gravatar imagerrottach ( 2017-03-29 15:05:52 -0500 )edit

This is issue for me with the same error. I misspelled the password in config file. I just deleted the MySQL database and recreated the database, user, password and synced them again. It worked perfectly afterwards.

Gowtham Sadasivam gravatar imageGowtham Sadasivam ( 2017-06-13 04:08:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-31 05:46:13 -0500

Seen: 5,608 times

Last updated: Jul 31 '16