manila configuration

asked 2016-07-29 03:42:26 -0500

openstackstarter gravatar image

Hi. I'm using 3node architecture and following through Openstack Guide Mitaka for Ubuntu. I've successfully installed Manila and servce list shows fine as below. As guide suggessts I installed scheduler and api on controller, and manila-share on compute node. But now I can't use any of manila-manage command with the following error, and can't trace what is triggering the error. DB is mysql, and my network agent is Openvswitch. How do I solve this? I will provide any information needed more.

Doc I'm following1. : http://docs.openstack.org/mitaka/install-guide-ubuntu/manila-verify.html (http://docs.openstack.org/mitaka/inst...) 2.http://docs.openstack.org/developer/manila/adminref/quick_start.html(this is not for multi-node guide, so only referencing configuration options, but I'm stuck where this site says

Then create manila’s tables and apply all migrations:

$ manila-manage db sync

manila servce-list

+----+------------------+--------------+------+---------+-------+----------------------------+
| Id | Binary           | Host         | Zone | Status  | State | Updated_at                 |
+----+------------------+--------------+------+---------+-------+----------------------------+
| 1  | manila-scheduler | control-node | nova | enabled | up    | 2016-07-29T08:28:54.000000 |
| 2  | manila-share     | compute-node | nova | enabled | down  | 2016-07-29T08:21:20.000000 |
+----+------------------+--------------+------+---------+-------+----------------------------+

manila-manage db sync

File "/usr/bin/manila-manage", line 6, in <module>
    from manila.cmd.manage import main
  File "/usr/lib/python2.7/dist-packages/manila/cmd/manage.py", line 65, in <module>
    from oslo_log import log
  File "/usr/lib/python2.7/dist-packages/oslo_log/log.py", line 49, in <module>
    from oslo_log import _options
  File "/usr/lib/python2.7/dist-packages/oslo_log/_options.py", line 15, in <module>
    from oslo_log import versionutils
  File "/usr/lib/python2.7/dist-packages/oslo_log/versionutils.py", line 52, in <module>
    class deprecated(object):
  File "/usr/lib/python2.7/dist-packages/oslo_log/versionutils.py", line 125, in deprecated
    '%(what)s is deprecated as of %(as_of)s in favor of '
  File "/usr/lib/python2.7/dist-packages/oslo_i18n/_factory.py", line 83, in f
    return _message.Message(msg, domain=domain)
  File "/usr/lib/python2.7/dist-packages/oslo_i18n/_message.py", line 60, in __new__
    msgtext = Message._translate_msgid(msgid, domain)
  File "/usr/lib/python2.7/dist-packages/oslo_i18n/_message.py", line 104, in _translate_msgid
    system_locale = locale.getdefaultlocale()
  File "/usr/lib/python2.7/locale.py", line 543, in getdefaultlocale
    return _parse_localename(localename)
  File "/usr/lib/python2.7/locale.py", line 475, in _parse_localename
    raise ValueError, 'unknown locale: %s' % localename
ValueError: unknown locale: UTF-8

vi /etc/manila/manila.conf on controller

[DEFAULT]
my_ip=10.0.0.1
rpc_backend = rabbit
default_share_type=default_share_type
rootwrap_config=/etc/manila/rootwrap.conf
api_paste_config=/etc/manila/api-paste.ini
auth_strategy=keystone
osapi_share_extension=manila.api.contrib.standard_extensions
state_path=/opt/stack/data/manila
[database]
connection = mysql+pymysql://manila:maniladbpass@10.0.0.1/manila
[keystone_authtoken]
auth_uri = http://control-node:5000
auth_url = http://control-node:35357
memcached_servers=10.0.0.1:11211
auth_plugin=password
project_domain_name=default
user_domain_name=default
project_name=service
username=manila
password=manilapass
[oslo_concurrency]
lock_path=/var/lib/manila/tmp

vi /etc/manila/manila.conf on compute node

[DEFAULT]
my_ip=10.0.0.3
rpc_backend = rabbit
default_share_type=default_share_type
rootwrap_config=/etc/manila/rootwrap.conf
auth_strategy=keystone
enable_share_backends=generic
enable_share_protocols=NFS,CIFS

state_path=/opt/stack/data/manila
osapi_share_extension=manila.api.contrib.standard_extensions
api_paste_config=/etc/manila/api-paste.ini
scheduler_driver=manila ...
(more)
edit retag flag offensive close merge delete

Comments

The manila-manage command to populate the database should be run as su -s /bin/sh -c "manila-manage db sync" manila on the controller.

barry.davis gravatar imagebarry.davis ( 2016-07-29 08:00:06 -0500 )edit

Hi barry, thank you for the comment. Unfortunately, command line you provided returns the same error..

openstackstarter gravatar imageopenstackstarter ( 2016-08-01 23:26:42 -0500 )edit