Ask Your Question
0

Can not Launch Environment

asked 2016-07-28 14:32:22 -0500

mmalik gravatar image

Whenever I attempt to launch a environment in murano I get the following error

Error: Failed to create environment

Error: {"explanation": "The server has either erred or is incapable of performing the requested operation.", "code": 500, "error": {"message": "Authorization failed: SSL exception connecting to https://public.fuel.local:5000/v3/auth/tokens (https://public.fuel.local:5000/v3/aut...): [Errno 1] _ssl.c:510: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed", "traceback": null, "type": "AuthorizationFailure"}, "title": "Internal Server Error"} (HTTP 500)

Two changes were made before I noticed this error: enabling nova quotas, and changing public URL for the keystone endpoint I don't believe either of these changes could be causing the issue.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-08-15 09:55:11 -0500

mmalik gravatar image

The issues was with the keystone haproxy certificate config I made a change to point keystone to a new cert that I generated which was causing the error. I restored the config to the default and that fixed it.

020-keystone-1.cfg

listen keystone-1 bind 10.x.x.x:5000 ssl crt /var/lib/astute/haproxy/new_public_haproxy.pem ---> Bad config with new cert bind 10.x.x.x:5000 ssl crt /var/lib/astute/haproxy/public_haproxy.pem ---> Default conifg

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-28 14:32:22 -0500

Seen: 422 times

Last updated: Aug 15 '16