vm unable to get ip neutron with vmware nsx plugin

asked 2016-07-28 03:39:06 -0600

vaidyanath-m gravatar image

Hi All, here is my setup details

1- Controller node Services - keystone, glance, neutron, nova neutron plugins used - vmware-nsx - https://github.com/openstack/vmware-nsx/ neutron agents - openvswitch agent 2- compute node Services - nova-compute

I have all the services up and running. but when i provision the vm the vm is not assigning the IP address which is offered from DHCP server

here are the config details:-

root@controller:~# neutron net-show test +---------------------------+--------------------------------------+ | Field | Value | +---------------------------+--------------------------------------+ | admin_state_up | True | | created_at | 2016-07-28T13:35:22 | | description | | | id | be2178a3-a268-47f4-809e-8e0024c6f054 | | name | test | | port_security_enabled | True | | provider:network_type | vlan | | provider:physical_network | dvs | | provider:segmentation_id | 110 | | router:external | False | | shared | True | | status | ACTIVE | | subnets | 5009ec57-4ca7-4e2b-962e-549e6bbee408 | | tags | | | tenant_id | ce581005def94bb1947eac9ac15f15ea | | updated_at | 2016-07-28T13:35:22 | +---------------------------+--------------------------------------+

root@controller:~# neutron subnet-show testsubnet +-------------------+------------------------------------------------------+ | Field | Value | +-------------------+------------------------------------------------------+ | allocation_pools | {"start": "192.168.18.246", "end": "192.168.18.248"} | | cidr | 192.168.18.0/24 | | created_at | 2016-07-28T14:56:54 | | description | | | dns_nameservers | 192.168.13.12 | | enable_dhcp | True | | gateway_ip | 192.168.18.1 | | host_routes | | | id | 5009ec57-4ca7-4e2b-962e-549e6bbee408 | | ip_version | 4 | | ipv6_address_mode | | | ipv6_ra_mode | | | name | testsubnet | | network_id | be2178a3-a268-47f4-809e-8e0024c6f054 | | subnetpool_id | | | tenant_id | ce581005def94bb1947eac9ac15f15ea | | updated_at | 2016-07-28T14:56:54 | +-------------------+------------------------------------------------------+

root@controller:~# ovs-vsctl show d516b5b1-db3f-4acd-856c-10d530c58c23 Bridge br-dvs Port br-dvs Interface br-dvs type: internal Port "eth1" Interface "eth1" Bridge br-int Port br-int Interface br-int type: internal Port "tap91d8accd-6d" Interface "tap91d8accd-6d" type: internal ovs_version: "2.5.0"

root@controller:~# ip netns qdhcp-be2178a3-a268-47f4-809e-8e0024c6f054

root@controller:~# ip netns exec qdhcp-be2178a3-a268-47f4-809e-8e0024c6f054 ifconfig lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

tap91d8accd-6d Link encap:Ethernet HWaddr fa:16:3e:7f:5e:03 inet addr:192.168.18.246 Bcast:192.168.18.255 Mask:255.255.255.0 inet6 addr: fe80::f816:3eff:fe7f:5e03/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:8 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:648 (648.0 B)

root@controller:~# ping 192.168.18.246 PING 192.168.18.246 (192.168.18.246) 56(84) bytes of data. ^C --- 192.168.18.246 ping statistics --- 20 packets transmitted, 0 received, 100% packet loss, time 18999ms

I dont have any agents running. because vmware_nsx should be taking care of the communication with openvswitch.

Commandline: apt install openvswitch-switch Install: openvswitch-switch:amd64 (2.5.0-0ubuntu1~cloud0), openvswitch-common:amd64 (2.5.0-0ubuntu1~cloud0, automatic)

edit retag flag offensive close merge delete