Ask Your Question
0

You are not authorized : identity:create_service

asked 2016-07-26 06:53:18 -0500

Mongrel gravatar image

updated 2016-08-01 09:12:54 -0500

rbowen gravatar image

On my test ENV we are getting this error, is there any way to resolve it. Reference Site

When running below openstack command on controller terminal, it says not authorized to perform requested action

[root@controller keystone]# openstack service create \
>   --name keystone --description "OpenStack Identity" identity
You are not authorized to perform the requested action: identity:create_service (HTTP 403) (Request-ID: req-59a67c10-1e89-46b8-b2b4-60b9be0e2d0e)
[root@controller keystone]# openstack service create   --name keystone --description "OpenStack Identity" identity
You are not authorized to perform the requested action: identity:create_service (HTTP 403) (Request-ID: req-9cd5adab-7069-427f-a4fa-75ee9b1e830e)
[root@controller keystone]#

Below is the log generated while the above command is executed

tailf /var/log/keystone/keystone.log

2016-07-26 17:07:48.671 5991 WARNING keystone.assignment.core [req-9d54e12b-96aa-4564-969f-1ce67146d031 - - - - -] Deprecated: Use of the identity driver config to automatically configure the same assignment driver has been deprecated, in the "O" release, the assignment driver will need to be expicitly configured if different than the default (SQL).
2016-07-26 17:07:48.808 5991 WARNING keystone.middleware.auth [req-a6dde17d-5def-4c52-bf86-703331dd8d84 - - - - -] Deprecated: build_auth_context middleware checking for the admin token is deprecated as of the Mitaka release and will be removed in the O release. If your deployment requires use of the admin token, update keystone-paste.ini so that admin_token_auth is before build_auth_context in the paste pipelines, otherwise remove the admin_token_auth middleware from the paste pipelines.
2016-07-26 17:07:48.846 5991 INFO keystone.common.wsgi [req-a6dde17d-5def-4c52-bf86-703331dd8d84 - - - - -] POST http://controller:35357/v3/services
2016-07-26 17:07:48.849 5991 WARNING keystone.common.wsgi [req-a6dde17d-5def-4c52-bf86-703331dd8d84 - - - - -] You are not authorized to perform the requested action: identity:create_service
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-08-04 07:34:41 -0500

jckreddy gravatar image
Make sure you have exported auth token and OS_URL properly 

export OS_TOKEN=<Random-key>
export OS_URL=http://controller:35357/v2.0  

Where controller is your controller hostname 

you can verify the above commands with "env"  on your machine
edit flag offensive delete link more

Comments

It worked, thanks.

Mongrel gravatar imageMongrel ( 2016-08-09 02:37:37 -0500 )edit
0

answered 2016-08-04 09:36:24 -0500

shamail gravatar image

Additional information on how to authenticate using both V2.0 and V3 identity services can be found in the http://docs.openstack.org/developer/python-openstackclient/authentication.html (Authentication section) of the OpenStack Client documentation. I would recommend validating your environment against this document.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-26 06:39:19 -0500

Seen: 2,087 times

Last updated: Aug 04 '16