Ask Your Question
1

OpenStack RDO mysqld 100% cpu

asked 2016-07-25 20:43:22 -0500

whollandsworth gravatar image

I've just installed the default RDO packstack OpenStack install. After about 5 minutes mysqld shoots up to 100% CPU and stays. This is causing horizon to basically become unusable. Anyone else have this issue? I can add more info if needed. Thanks in advance.

edit retag flag offensive close merge delete

Comments

If you have more info to add, I would recommend that you go ahead and do so. Perhaps also watch the mysqld query log and see what it's working on?

rbowen gravatar imagerbowen ( 2016-07-29 15:15:45 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-11-07 23:37:40 -0500

long gravatar image

updated 2016-11-07 23:39:55 -0500

Hi whollandsworth, Does it fixed? How do you fix this issue, i have encountered the same issue on my openstack mitaka cloud

edit flag offensive delete link more

Comments

I have fixed this issue on my mitaka cloud with expanding the LimitNOFILE in this configure file

$ cat /etc/systemd/system/mariadb.service.d/limits.conf [Service] LimitNOFILE=10000

long gravatar imagelong ( 2016-11-15 01:08:24 -0500 )edit
0

answered 2016-11-04 06:51:21 -0500

hdamf gravatar image

I also see this happening regularly. File /var/log/mariadb/mariadb.log is full of

2016-11-04 12:45:23 140456190351488 [ERROR] Error in accept: Bad file descriptor

There are tons of it:

# grep -c "Error in accept: Bad file descriptor" /var/log/mariadb/mariadb.log
17276184
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-25 20:43:22 -0500

Seen: 437 times

Last updated: Nov 07 '16