Adding a compute node with RDO - Puppet/Hiera error? [closed]

asked 2016-07-25 10:18:13 -0500

mtr gravatar image

updated 2016-07-26 14:32:40 -0500

Hi. I am attempting to add a compute node to my POC single-node OpenStack Liberty cloud.

I initially set up the node by following the "Packstack quickstart" instructions (https://www.rdoproject.org/install/quickstart/ (https://www.rdoproject.org/install/qu...)) on the RDO site, and the single node is working as expected.

I am trying to continue by following the "Adding a compute node" instructions (https://www.rdoproject.org/install/adding-a-compute-node/ (https://www.rdoproject.org/install/ad...)). However, each time I run Packstack, the installation errors out with an apparent Hiera issue when it attempts to apply a Puppet manifest to my new compute node.

Also noteworthy, maybe? - I am being prompted repeatedly for root passwords throughout the installation process. Could be a related issue?

I see that a very similar issue (https://bugzilla.redhat.com/show_bug.cgi?id=1284978 (https://bugzilla.redhat.com/show_bug....)) was marked as a bug back in November, but it appears that the issue is supposed to be fixed as of openstack-packstack-7.0.0-0.7. I currently have openstack-packstack-7.0.1-0.13, for which I can't find any questions or issue reports.

Any thoughts? Thanks in advance!

Copying Puppet modules and manifests                 [ DONE ]
Applying 9.3.84.121_prescript.pp
root@9.3.84.121's password: 
Applying 9.3.84.122_prescript.pp
root@9.3.84.122's password: 
Testing if puppet apply is finished: 9.3.84.121_prescript.pp  [ / ]root@9.3.84.121's password: 
9.3.84.121_prescript.pp:                             [ DONE ]      
Testing if puppet apply is finished: 9.3.84.122_prescript.pp  [ | ]root@9.3.84.122's password: 
9.3.84.122_prescript.pp:                          [ ERROR ]        
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 9.3.84.122_prescript.pp
Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item CONFIG_USE_SUBNETS in any Hiera data file and no default supplied at /var/tmp/packstack/0c19719755a14795b53f2efb939db86b/manifests/9.3.84.122_prescript.pp:2:22 on node g150

Edit 1: Repeated prompting for root password was corrected by setting up passwordless SSH. Other issue still applies.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by mtr
close date 2016-07-27 14:13:09.142710

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-07-27 14:12:47 -0500

mtr gravatar image

While I could not find cause or resolution for this issue in Liberty, I did find that my installation and node addition worked just fine if I followed the same steps in Mitaka.

My project has no particular need to use Liberty over Mitaka, so I'm considering this issue closed, for my intents and purposes.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-25 10:18:13 -0500

Seen: 421 times

Last updated: Jul 27 '16