Ask Your Question
1

Problem creating flat network: "Unknown provider:physical_network physnet1"

asked 2013-12-25 20:41:08 -0500

bretmcmillan gravatar image

I'm trying to create a very simple home lab setup using a /26 block of my existing network. My current understanding is I want a "flat, no dhcp" setup. Towards that end, I've added the following to ovs_neutron_plugin.ini :

network_vlan_ranges = physnet1

When I try to create the network, I get the following error:

[root@uberwald neutron(keystone_admin)]# neutron net-create home-network --provider:network_type flat --provider:physical_network physnet1

400-{u'NeutronError': {u'message': u'Invalid input for operation: Unknown provider:physical_network physnet1.', u'type': u'InvalidInput', u'detail': u''}}

What else do I need to do to create physnet1 for use w/ this command?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-01-03 15:22:36 -0500

jfulton gravatar image

I had this issue ("Invalid input for operation: physical_network 'physnet1' unknown for flat provider network.") and I needed to update /etc/neutron/plugins/ml2/ml2_conf.ini to specify my list of physical_network names with which flat, vlan, gre, etc type networks can be created; e.g. under [ml2_type_flat] I set "flat_networks = *" to get around the issue.

edit flag offensive delete link more

Comments

That just works fine :D

Harry996 gravatar imageHarry996 ( 2019-08-24 04:08:00 -0500 )edit
0

answered 2013-12-26 19:47:12 -0500

SamYaple gravatar image

updated 2013-12-27 06:54:45 -0500

Make sure you map the physnet1 to a bridge in your ovs ini file.

[ovs]
bridge_mappings = physnet1:br-eth0

Make sure you have it under the right section [ovs]

[ovs]
network_vlan_ranges = physnet1

In addition to all of that, turn on verbose and debugging in the neutron.conf file and grep the log for "physnet1" as it starts up to see if it is in the log.

[DEFAULT]
verbose = True
debug = True
edit flag offensive delete link more

Comments

1

Vlans are not needed if using flat networks. This line should be fine: network_vlan_ranges = physnet1

fetahi gravatar imagefetahi ( 2013-12-27 01:02:35 -0500 )edit

updated the answer, the option name threw me off. Thanks

SamYaple gravatar imageSamYaple ( 2013-12-27 06:56:29 -0500 )edit

how is your setup?

senyapsudah gravatar imagesenyapsudah ( 2014-04-17 04:07:56 -0500 )edit

I am using VXLANs with openvswitch in a full SDN. I didn't end up using the switches for any networking at all

SamYaple gravatar imageSamYaple ( 2014-04-17 08:12:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-12-25 20:41:08 -0500

Seen: 10,265 times

Last updated: Dec 27 '13