Failed to bind port on host compute

asked 2016-07-19 11:38:52 -0500

bilbil2000 gravatar image

I have problem. I'm trying to launch an instance in dashboard and I'm getting this error:

No valid host was found. There are not enough hosts available

and, cat /var/log/neutron/server.log | grep Failed on controller node

Failed to bind port 540d2ec5-c9dd-401e-9b81-a94d0e432d73 on host compute1

/etc/neutron/plugins/ml2/linuxbridge_agent.ini

[linux_bridge]
physical_interface_mappings = pulic:eno1
[vxlan]
enable_vxlan = False
[agent]
prevent_arp_spoofing = True
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver
enable_security_group = True

eno1's IP = 10.0.0.11

How I can launch an instance? Please help...

edit retag flag offensive close merge delete

Comments

Check the spelling on physical_interface_mappings = pulic:eno1 in linuxbridge_agent.ini and that it matches flat_network = public in ml2_conf.ini.

barry.davis gravatar imagebarry.davis ( 2016-07-19 14:44:04 -0500 )edit

I chenged spell, but I could't.

in linuxbridge_agent.ini

physical_interface_mappings = public:eno1

in ml2_conf.ini

flat_network = public
bilbil2000 gravatar imagebilbil2000 ( 2016-07-20 00:04:32 -0500 )edit

Maybe node's setting is wrong

controller node settings ens6f0 => 172.21.34.65 eno0 => 10.0.0.11

conpute node settings ens6f0 => 172.21.34.69 eno0 => 10.0.0.21

bilbil2000 gravatar imagebilbil2000 ( 2016-07-20 01:25:18 -0500 )edit

Output of neutron port-show 540d2ec5-c9dd-401e-9b81-a94d0e432d73

Mohit gravatar imageMohit ( 2016-07-20 12:03:33 -0500 )edit

Sorry Im late. neutron port-show 540d2ec5-c9dd-401e-9b81-a94d0e432d73 ↓ Unable to find port with name '540d2ec5-c9dd-401e-9b81-a94d0e432d73'

bilbil2000 gravatar imagebilbil2000 ( 2016-07-28 07:23:25 -0500 )edit