Ask Your Question
0

should bridges(br-int,tun,ex) UP ?

asked 2016-07-19 05:08:30 -0500

openstackstarter gravatar image

Hi, I'm deploying 3node architecture with Openstack Mitaka on Ubuntu server and having problem with networking. My instance doesn't have an access to internet in and out. if bridges up correctly, should br-in& br-tun be shown in ifconfig too? I manually changed /etc/network/interfaces so that br-ex can be up. Shouldn't they automatically up themselves? If they should, why mine don't? How can I fix it? Or, should I manually add lines to /etc/network/interfaces to make all bridges' status up everytime rebooting? How can I check if bridges UP or not? On compute-node , happens the same.

Here are some info. I will update any info needed more. Thanks in advance.

Network-node

ovs-vsctl show

Bridge br-int
        fail_mode: secure
        Port "tapfb30254d-41"
            tag: 3
            Interface "tapfb30254d-41"
        Port "tap506d7b9c-45"
            tag: 3
            Interface "tap506d7b9c-45"
        Port br-int
            Interface br-int
                type: internal
        Port "tape3ab3190-7f"
            tag: 2
            Interface "tape3ab3190-7f"
        Port "tap102f5631-8c"
            tag: 1
            Interface "tap102f5631-8c"
        Port "tap13921519-ef"
            tag: 1
            Interface "tap13921519-ef"
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port "tap8fe83bc7-52"
            tag: 2
            Interface "tap8fe83bc7-52"
    Bridge br-ex
        Port "wlan0"
            Interface "wlan0"
        Port br-ex
            Interface br-ex
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
    Bridge br-tun
        fail_mode: secure
        Port "gre-0a000003"
            Interface "gre-0a000003"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="10.0.0.2", out_key=flow, remote_ip="10.0.0.3"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
                type: internal
    ovs_version: "2.5.0"

ifconfig

br-ex     Link encap:Ethernet  HWaddr 90:9f:33:ef:38:3c  
          inet addr:192.168.0.37  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::929f:33ff:feef:383c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:539 errors:0 dropped:0 overruns:0 frame:0
          TX packets:79 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:81886 (81.8 KB)  TX bytes:10415 (10.4 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:54 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:4180 (4.1 KB)  TX bytes:4180 (4.1 KB)

p3p1      Link encap:Ethernet  HWaddr e8:11:32:31:9f:f2  
          inet addr:10.0.0.2  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::ea11:32ff:fe31:9ff2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11055 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1353 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:959511 (959.5 KB)  TX bytes:262555 (262.5 KB)

tap102f5631-8c Link encap:Ethernet  HWaddr e6:50:f0:fe:09:79  
          UP BROADCAST RUNNING MULTICAST ...
(more)
edit retag flag offensive close merge delete

Comments

br-int and br-tun should be up and set to ip address 0 , you can do it via cli , ifconfig br-int up and ifconfig br-tun up

Mohit gravatar imageMohit ( 2016-07-20 12:08:34 -0500 )edit
1

this is incorrect

darragh-oreilly gravatar imagedarragh-oreilly ( 2016-07-20 12:45:39 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-07-19 07:27:48 -0500

In my working Mitaka/OVS configuration the bridge interfaces br-int and br-tun are always reported as DOWN. The br-ex bridge interface always reports as UNKNOWN. Only my physical network interface reports as UP. See this post. I also note you are attempting to use a wireless interface in your configuration. I have found that wireless interfaces do not work well with bridge configurations and can only be used for the management interface (no bridge). I suggest you configure the br-ex bridge with physical interface p3p1 as a port on that bridge.

edit flag offensive delete link more

Comments

Thanks Barry for your detailed answer. On my network node, br-int & br-tun are DOWN, and so is br-ex. Is that okay? I'm just not sure that UNKNOWN is same as DOWN.

openstackstarter gravatar imageopenstackstarter ( 2016-07-25 01:16:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-19 05:08:30 -0500

Seen: 782 times

Last updated: Jul 20 '16