Ask Your Question
1

No IP address obtained by overcloud nodes during PXE boot when trying to deploy with TripleO

asked 2016-07-15 02:09:05 -0500

OpSourceTrail gravatar image

Hi, I've got an issue with deploying overcloud with TripleO. There are two nodes in my lab - one for controller, one for compute. Introspection works well, as expected. The problem comes when I try to deploy the overcloud:

openstack overcloud deploy --templates --control-scale 1 --compute-scale 1 --compute-flavor compute --control-flavor control

What happens is that the overcloud nodes do not obtain an IP address. Strange is the fact that if I run dnsmasq on foreground on the Director system, I can clearly see that it receives the DHCP request and that it sends respond. Unfortunately, the response never reach the client (prooved by tcpdump)!

dnsmasq-dhcp: 3590489911 available DHCP subnet: 192.0.2.0/255.255.255.0
dnsmasq-dhcp: 3590489911 available DHCP range: 192.0.2.100 -- 192.0.2.120
dnsmasq-dhcp: 3590489911 DHCPDISCOVER(tap141f42ce-e0) 5c:f3:fc:2c:31:49 
dnsmasq-dhcp: 3590489911 tags: tap141f42ce-e0
dnsmasq-dhcp: 3590489911 DHCPOFFER(tap141f42ce-e0) 192.0.2.112 5c:f3:fc:2c:31:49
dnsmasq-dhcp: 3590489911 requested options: 1:netmask, 28:broadcast, 2:time-offset, 121:classless-static-route, 
dnsmasq-dhcp: 3590489911 requested options: 15:domain-name, 6:dns-server, 12:hostname, 
dnsmasq-dhcp: 3590489911 requested options: 40:nis-domain, 41:nis-server, 42:ntp-server, 
dnsmasq-dhcp: 3590489911 requested options: 26:mtu, 119:domain-search, 3:router
dnsmasq-dhcp: 3590489911 bootfile name: pxelinux.0
dnsmasq-dhcp: 3590489911 server name: localhost.localdomain
dnsmasq-dhcp: 3590489911 next server: 192.0.2.1
dnsmasq-dhcp: 3590489911 sent size:  1 option: 53 message-type  2
dnsmasq-dhcp: 3590489911 sent size:  4 option: 54 server-identifier  192.0.2.20
dnsmasq-dhcp: 3590489911 sent size:  4 option: 51 lease-time  2m
dnsmasq-dhcp: 3590489911 sent size:  4 option: 58 T1  1m
dnsmasq-dhcp: 3590489911 sent size:  4 option: 59 T2  1m45s
dnsmasq-dhcp: 3590489911 sent size:  4 option:  1 netmask  255.255.255.0
dnsmasq-dhcp: 3590489911 sent size:  4 option: 28 broadcast  192.0.2.255
dnsmasq-dhcp: 3590489911 sent size:  4 option:  3 router  192.0.2.20

Any idea what could cause this? The OpenStack release is Liberty.

Thanks, Jan

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2018-10-26 08:30:29 -0500

I just had the same problem installing Queens, using the ramdisk images from https://images.rdoproject.org/master/delorean/current-tripleo-rdo-internal/ (https://images.rdoproject.org/master/...) dated 2018-10-02.

The fix was to add a root password to the kernal parameters in /httpboot/inspector.ipxe on the undercloud, start introspection, boot into each node once it had loaded the ramdisk, and run 'ifup' on my interface to fetch the IP properly.

edit flag offensive delete link more
0

answered 2017-01-17 21:22:42 -0500

tony.pearce gravatar image

The issue is because DHCP is not implemented properly in OpenStack. We need to remove the introspection dhcp range because it is causing deployment to fail. Since this is such an old post, I wont go into detail. I'm trying to get Red Hat to raise a bugzilla.

edit flag offensive delete link more
0

answered 2017-01-07 11:44:24 -0500

Any one can answer the solution for this problem ?

edit flag offensive delete link more
0

answered 2016-11-24 00:45:54 -0500

You got any solution for this. I am having the same issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-14 18:04:55 -0500

Seen: 809 times

Last updated: Nov 24 '16