Ask Your Question
0

openstack mitaka on VM, can not ping floatingip of inner guest VM

asked 2016-07-13 22:57:04 -0600

xugangsh gravatar image

Hi all,

I have one CentOS 7 VM and installed Openstack Mitaka ready

I used OVS and create two networks, one is public network and the other is internal network

I upload cirros image for some simple test

I deployed one guest vm from cirros image and associate floatingip

Then I logined to host and try to ping this new VM floating ip, but failed

I checked security group and found I did set for icmp and tcp

I did know most openstack installed on physical host

But we are in CI test, so use VM to install openstack run some tempest

Could anyone support me to fix this problem? I searched in web and found many solution, but not work.

Below is some info for our env.

host ip: 108.11.11.3/24 public network: 108.11.11.0/24, floatingip range: 108.11.11.220-250 internal network: 192.168.10.0/24

guest VM ip: 192.168.10.59, floatingip: 108.11.11.226

router ip: 108.11.11.221, gateway: 192.168.10.1

  1. I logined to 108.11.11.3 and ping 108.11.11.226 failed
  2. ip netns list ... qrouter-375934b5-ad4d-4474-9aa6-f127d809a43b

  3. from router, try to ping guest vm ip netns exec qrouter-375934b5-ad4d-4474-9aa6-f127d809a43b ping -c 4 108.11.11.226 PING 108.11.11.226 (108.11.11.226) 56(84) bytes of data. 64 bytes from 108.11.11.226: icmp_seq=1 ttl=64 time=2.37 ms 64 bytes from 108.11.11.226: icmp_seq=2 ttl=64 time=0.584 ms 64 bytes from 108.11.11.226: icmp_seq=3 ttl=64 time=0.584 ms 64 bytes from 108.11.11.226: icmp_seq=4 ttl=64 time=0.526 ms

  4. ping -c 108.11.11.221 failed

Thanks!

BRs/Xu Gang

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-07-14 00:04:11 -0600

I think it's a MTU problem.

If you have dnsmasq-neutron.conf file.

you can edit dhcp-option-force=26,1450 and saved.

If you don't have dnsmasq-neutron.conf file.

you check this link. http://docs.openstack.org/draft/netwo...

Then restart dhcp-agent.

edit flag offensive delete link more

Comments

Tried solution but still not work.

Thanks!

xugangsh gravatar imagexugangsh ( 2016-07-14 00:43:58 -0600 )edit

Oh... T_T

Did you check dhcp_agent.ini file?

If you using dnsmasq-neutron.conf file...

you check dnsmasq_config_file = /etc/neutron/dnsmasq-neutron.conf ?

this line in dhcp_agent.ini file.

uni2u gravatar imageuni2u ( 2016-07-14 01:41:18 -0600 )edit
0

answered 2016-07-14 00:43:08 -0600

xugangsh gravatar image

Below is part of my dnsmasq.conf

Send options to PXELinux. Note that we need to send the options even

though they don't appear in the parameter request list, so we need

to use dhcp-option-force here.

See http://syslinux.zytor.com/pxe.php#spe... for details.

Magic number - needed before anything else is recognised

dhcp-option-force=208,f1:00:74:7e

Configuration file name

dhcp-option-force=209,configs/common

Path prefix

dhcp-option-force=210,/tftpboot/pxelinux/files/

Reboot time. (Note 'i' to send 32-bit value)

dhcp-option-force=211,30i

dhcp-option-force=26,1450

I updated as above and restart neutron-dhcp-agent service But it did not work.

My env has two nics, one is for management ip and the other is used for openstack And my network ml2 is OVS

I did check by use tcpdump to track, seemed packet was received and responsed For example

[root@test18177 etc]# ip a 1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever 2: eth0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether fa:16:3e:bd:3a:43 brd ff:ff:ff:ff:ff:ff inet 108.11.11.3/24 brd 108.11.11.255 scope global dynamic eth0 valid_lft 83554sec preferred_lft 83554sec 3: eth1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000 link/ether fa:16:3e:f0:74:ea brd ff:ff:ff:ff:ff:ff

[root@test18177 etc]# tcpdump -i eth1 -v tcpdump: WARNING: eth1: no IPv4 address assigned tcpdump: listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes

Run command tcpdump -i eth1 -v

05:40:25.012497 IP (tos 0x0, ttl 64, id 3216, offset 0, flags [DF], proto ICMP (1), length 84) test18177 > 108.11.11.226: ICMP echo request, id 29548, seq 1, length 64 05:40:25.015012 IP (tos 0x0, ttl 63, id 64928, offset 0, flags [none], proto ICMP (1), length 84) 108.11.11.226 > test18177: ICMP echo reply, id 29548, seq 1, length 64 05:40:26.011599 IP (tos 0x0, ttl 64, id 3217, offset 0, flags [DF], proto ICMP (1), length 84) test18177 > 108.11.11.226: ICMP echo request, id 29548, seq 2, length 64 05:40:26.012375 IP (tos 0x0, ttl 63, id 65109, offset 0, flags [none], proto ICMP (1), length 84) 108.11.11.226 > test18177: ICMP echo reply, id 29548, seq 2, length 64 05:40:27.011620 IP (tos 0x0, ttl 64, id 3218, offset 0, flags [DF], proto ICMP (1), length 84) test18177 > 108.11.11.226: ICMP echo request, id 29548, seq 3, length 64 05:40:27.012155 IP (tos 0x0, ttl 63, id 65279, offset 0, flags [none], proto ICMP (1), length 84) 108.11.11.226 > test18177: ICMP echo reply, id 29548, seq 3, length 64 05 ... (more)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-13 22:57:04 -0600

Seen: 139 times

Last updated: Jul 14 '16