mirantis Software dependency error installing Mirantis 9.0 with PXE

asked 2016-07-13 07:40:54 -0500

pmalagon gravatar image

I have tried to install using PXE the Mirantis 9.0 distribution.

I mounted the iso in a HTTP server, and set it in the PXE. I have checked, using a web browser, that it is reachable.

The CentOS 7.2.1511 installation GUI launches correctly. However, selecting Minimal install shows a red message "Error checking software selection". When clicking for details the errors are: 2:postfix-2.10.1-6.el7.x86_64 requires libmysqlclient.so.18()(64-bit) 2:postfix-2.10.1-6.el7.x86_64 requires libmysqlclient.so.18(libmysqlclient_18)(64-bit) firewalld-0.3.9-14.el7.noarch requires python-decorator python-slip-dbus-0.4.0-2.el7.noarch requires python-decorator tuned-2.5.1-4.el7.noarch requires python-decorator

If I change the repo URL from my HTTP server to an official CentOS mirror, everything goes properly and it starts the installation (without any Mirantis modification, if any).

I have seen that python-decorator package is not available in Packages directory (it is available in a standard CentOS) of the Mirantis ISO, although it is available in the folder mos-centos/Packages.

Does anyone have a clue on how to solve this installation issue?

edit retag flag offensive close merge delete