Openstack Installer Public IP of Horizon

asked 2016-07-11 14:35:09 -0500

bobbybackblech gravatar image

updated 2016-07-12 00:11:22 -0500

I installed Openstack as a Single Installation as described in the Docs

So far it seems that all Services were installed successfully. The Problem i have is that the Dashboard / Horizon has an internal IP Address so i cant access the actual Dashboard with my Browser.

Is there any Workaround to give the Dashboard a Public IP Address so i have access to the Dashboard?

How can i access the Dashboard from the public?

There seems no Apache or nginx Server installed, do i have to install a webserver first? I did not found anything in the Docs. MYSQL is also not installed on the Server.

The Server has a Public IP, but as i said it seems that this Public IP is never used.

lxc-ls -f
NAME                   STATE    IPV4                                   IPV6  AUTOSTART  
--------------------------------------------------------------------------------------
openstack-single-root  RUNNING  10.0.6.1, 10.100.1.230, 192.168.122.1  -     YES

openstack-status says the IP of the Dashboard is 10.0.6.151 which is an internal IP. The Login URL which is shown is https://10.0.6.151/horizon which is of course not reachable since its an internal Server IP.

image description

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2016-07-11 18:51:20 -0500

Is your single server have a public IP?

I think you have a public IP already.

Did you try connect http://<public_ip>/horizon ?

and checked /etc/nova/nova.conf

novncproxy_base_url = http://<single server="" public="" ip="">:6080/vnc_auto.html

If your network configuration is OK...

you can try add port forwarding.

ex)

iptables -t nat -A PREROUTING -p tcp -i eth0 --dport 80 -j DNAT --to-destination <ip>:80

iptables -A FORWARD -p tcp -d <ip> --dport 80 -m state --state NEW,ESTABLISHED,RELATED -j ACCEPT

(eth0 and IP is yours)

edit flag offensive delete link more

Comments

Really thanks for your answer.

The Server has a public IP yes. :) The File /etc/nova/nova.conf does not exist.

Is there maybe something wrong with the Installation? Since i dont even see an installed Webserver. MYSQL is also not installed on the Server.

I edited also my Question.

bobbybackblech gravatar imagebobbybackblech ( 2016-07-11 23:57:43 -0500 )edit

Are you using LXC?

Anyway I think you need a IP_FORWARDING.

Check this page http://ubuntuforums.org/showthread.ph...

uni2u gravatar imageuni2u ( 2016-07-12 18:38:18 -0500 )edit
0

answered 2020-06-01 15:26:01 -0500

uday kiran reddy gravatar image

I got a similar issue now.

I installed on azure.

Can access from other azure vm but not with public ip.

Can access http://<publicip> and showing apache test page.

But can't access

http://<publicip>/dashboard

Any update/solution for this?

edit flag offensive delete link more

Comments

You compare your case on Azure with somebody else's case four years ago on a different platform. This is not a similar issue. I suggest you create a new question and provide a detailed description of your problem.

From what you describe, I guess the OpenStack vhost doesn't listen on the public IP.

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-01 19:27:19 -0500 )edit

I raised a separate question but no response to that. Can you please check that once

uday kiran reddy gravatar imageuday kiran reddy ( 2020-06-06 12:55:15 -0500 )edit

I am afraid I know nothing about Azure and Azure public IPs.

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-06 18:21:07 -0500 )edit
0

answered 2016-07-11 19:37:30 -0500

centenor gravatar image

As long as the server you installed the all-in-one setup on has a public IP, you should be able to reach the Horizon dashboard.

You should be able to connect by going to http://your_ip/dashboard

If that is not working it might be a misconfiguration in /etc/openstack-dashboard/local_settings file. There is an option in that file that is OPENSTACK_HOST. The value for that should be OPENSTACK_HOST = "controller"

Let me know if that doesn't work

edit flag offensive delete link more

Comments

Thanks for your Answer. I have no Folder inside /etc/openstack-dashboard/ MySQL is also not installed. I edited also my Question to give more Details.

bobbybackblech gravatar imagebobbybackblech ( 2016-07-11 23:58:59 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-11 14:35:09 -0500

Seen: 2,392 times

Last updated: Jun 01