Ask Your Question

Unable to reach private network router

asked 2016-07-11 13:57:01 -0500

centenor gravatar image

updated 2016-07-11 16:11:03 -0500

Hi everyone,

I'm setting up OpenStack Liberty by following the install guide on the website. Everything is working great with the public network, but for some reason I am unable to get anything to work in the private network. We followed the steps for the self service provider networks but we can't seem to get it to work. I am unable to ping the gateway but i'm not seeing any errors popping up in the neutron server log. The private network for our setup is

Link to private project network part of guideL (

Here are a few outputs I thought would be helpful for people to see:

IP netns

qrouter-e1a43dc0-57a0-4231-bf38-cb69a66e20a7 (id: 2)
qdhcp-b2d35ed1-01c3-4050-a8ce-6011d4f2f41a (id: 1)
qdhcp-f03e2e8a-cadc-4d7f-8ad6-3651aac26d00 (id: 0)

neutron router-port-list router

| id                                   | name | mac_address       | fixed_ips                                                                            |
| 5ecdea30-bcb6-45c1-8a9f-e3b0e433ff64 |      | fa:16:3e:31:71:3c | {"subnet_id": "54776291-ac99-4acf-bef3-43dc20044046", "ip_address": ""} |
| 776a440c-5cdd-42cb-a232-68e9d431e29e |      | fa:16:3e:1a:bc:0e | {"subnet_id": "9f3d6d90-68f3-4a40-80cd-422a916a1756", "ip_address": ""}      |

neutron subnet-list

| id                                   | name    | cidr           | allocation_pools                                   |
| 54776291-ac99-4acf-bef3-43dc20044046 | public  | | {"start": "", "end": ""} |
| 9f3d6d90-68f3-4a40-80cd-422a916a1756 | private |    | {"start": "", "end": ""}         |

I'm trying to ping, which is the gateway for the private but that isn't working. I've also tried to set a static route on the virtual router that is Destination - and next hop is (This might be incorrect but I believe that the correct static route to set)

Any help would be appreciated! Let me know if anyone needs anything from any log file or other outputs

edit retag flag offensive close merge delete


Are you trying to ping from outside? If yes, then private networks are not accessible from an external network. You need to have a floating IP to do so. If not, then you might want to check security groups.

kaustubh gravatar imagekaustubh ( 2016-07-11 19:37:52 -0500 )edit

I'm trying to ping from the internal public network but that isn't working. The private router has the internal public network's gateway as it's external gateway, so that is why i'm confused as to why I can't reach the internal private network from the internal public network

centenor gravatar imagecentenor ( 2016-07-11 19:48:32 -0500 )edit


Any luck on this. I am also facing the similar issue. The problem is i am able to reach the internal gateway, but not able to ping the other instance on the same internal network.

Regards, Gaurav

gaurav.mittal gravatar imagegaurav.mittal ( 2019-08-03 22:50:06 -0500 )edit

The original question was asked three years ago. The original problem: "I am unable to ping the gateway".

You, on the other hand, are able to ping the gateway. Obviously this is not a similar issue. I suggest you create your own question and provide some additional detail.

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-04 00:42:36 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2016-07-11 15:05:26 -0500

james-denton gravatar image

Did you attach the router to the private network?

neutron router-interface-add <routerid> <subnetid>

You can attach the router to the public network using:

neutron router-gateway-set <routerid> <networkid>

Give that a shot and then try again. If you did complete those steps we will need to look elsewhere.

edit flag offensive delete link more


Yes, I did run those two commands as part of the guide for setting up the private project network.On the guide it has me set it up this way:

neutron router-interface-add router private
neutron router-gateway-set router public
centenor gravatar imagecentenor ( 2016-07-11 16:09:16 -0500 )edit

answered 2016-07-11 18:59:06 -0500

Recheck your data network IPs.

and recreate private network. (different CIDR)

the GW is not working?

Is your data network IP and private IP range is same?

If data network IP and private IP range is same, you don't create same ranges private network.

edit flag offensive delete link more


I've tried recreate the private network about 2-3 times using the private project steps in the liberty guide but i'm never able to hit the Gateway. My data network range is192.168.1.0/24. I defined the private range as so they are two separate networks.Public range is - 200

centenor gravatar imagecentenor ( 2016-07-11 19:24:28 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-07-11 13:57:01 -0500

Seen: 866 times

Last updated: Aug 03 '19