Ask Your Question
1

Passwords not generating & Kolla not deploying correctly

asked 2016-07-10 15:53:13 -0500

updated 2016-07-11 01:14:47 -0500

Please help with resolving deployment issues with Kolla: Running Ubuntu Server on a KVM

So when I found that the passwords were not generating automatically with "kolla-genpwd", and that during deployment I received an error under "Starting Kolla-toolbox container" that said "unknown error message: Tag 3.0.0 not found in repository docker.io/kolla/centos-binary-kolla-toolbox"), and found that the container that was made after deployment was called: kolla/centos-binary-heka:3.0.0 when I specifically set the globals.yml to "Ubuntu" and "Binary", I decited to start over with a new harddrive, new virtural machine, and new Kolla installation to make sure I didn't miss anything during installation nor that there were not any conflicts from horizon and keystone that was previously installed on the Kernal. However Now I'm receiving the same messages as before.

Why will Kolla-genpwd not populate passwords automatically? (user has permissions in that directory, and I can edit passwords.yml, global.yml, or even all.yml manually)

What error is this I'm receiving during deployment? (also find 1 error in Kolla-ansible prechecks: 'dict object' has no attribute u'ansible_eth0'")

Why is the container deployed called "kolla/centos-binary-heka:3.0.0" when I specifically set globals.yml to "Ubuntu"? (is deployment ignoring my settings?)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-07-11 01:36:27 -0500

Hi @SpacemanSpiff

I'm going to start in order:

Kolla-toolbox has no tag 3.0.0 for now, recently Kolla has migrated the docker namespace from kollaglue to kolla [0]

Tag 3.0.0 is equivalent to master branch, is you are doing something like a PoC or testing use tag 2.0.1 equivalent to mitaka/stable release. If want to use master branch for development purposes, is better to build the images for yourself.

kolla-genpasswd not working, have you tried with sudo kolla-genpwd?

Is eth0 present at the nodes? If not, configure the interface you want to use at globals.yml. By default, have eth0 configured for network_interface.

This interface is what all your api services will be bound to by default. Additionally, all vxlan/tunnel and storage network traffic will go over this interface by default. This interface must contain an IPv4 address.

[0] [https://hub.docker.com/r/kolla/ubuntu...

Regards, Eduardo Gonzalez

edit flag offensive delete link more

Comments

Thanks for your response. I believe I did use "sudo kolla-genpwd" and no signs of it doing anything...just returns to command prompt...with no error either. passwords.yml in "kolla/etc/kolla/" looks the same. I'll test the rest that you mentioned tonight. Thank you.

SpacemanSpiff gravatar imageSpacemanSpiff ( 2016-07-11 08:23:52 -0500 )edit
0

answered 2016-12-08 18:01:04 -0500

sayantani.goswami gravatar image

kolla-genpwd will populate the passwords.yml file present in the /etc/kolla directory. Before running the kolla-genpwd command, copy the passwords.yml file from kolla/etc/kolla directory to /etc/kolla directory.

Why is the container deployed called "kolla/centos-binary-heka:3.0.0" when I specifically set globals.yml to "Ubuntu"? (is deployment ignoring my settings?)

Answer:

Make sure the base distro is changed to ubuntu in the kolla_build.conf file as well. By default, the base in the kolla_build.conf file is centos.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-10 15:53:13 -0500

Seen: 736 times

Last updated: Dec 08 '16