Ask Your Question
0

install error keystone and apache2

asked 2016-07-10 06:31:28 -0500

Soondong gravatar image

hi i 'm following the openstack mitaka installation guide for ubuntu 14.04lts for stopping keystone service i do sudo echo "manual" > /etc/init/keystone.override

-bash: /etc/init/keystone.override: Permission denied

i don't know how to resolve permission denied

so I do sudo service keystone stop apt-get install keystone apache2 libapache2-mod-wsgi. next update-rc.d -f keystone remove

 Removing any system startup links for /etc/init.d/keystone ...

I think update-rc.d command have same effect with sudo echo "manual" > /etc/init/keystone.override

then, i follow http://docs.openstack.org/mitaka/install-guide-ubuntu/keystone-install.html (http://docs.openstack.org/mitaka/inst...). in next step, i export OS_TOKEN, OS_URL, OS_IDENTITY_API_VERSION. but

openstack service create  --name keystone --description "OpenStack Identity" identity

error message Unable to establish connection to http://controller:35357/v3/services

i don't know my problem and solution.

thank you for reading my question.

edit retag flag offensive close merge delete

Comments

"sudo -s" before you run the echo command.

ajbanks gravatar imageajbanks ( 2016-09-15 16:28:02 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-10-13 00:31:08 -0500

sudo echo "manual" > /etc/init/keystone.override

For this you go to root access using su command & root pwd

then type echo "manual" > /etc/init/keystone.override

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-07-10 06:31:28 -0500

Seen: 225 times

Last updated: Jul 10 '16