Ask Your Question
0

keystone not following config file

asked 2013-12-24 07:10:39 -0500

OldParrothead gravatar image

I am trying to setup an all in one setup for a small office. To start, I am using the .deb files from a previous install to load the system, as I had multiple issues with the last upgrades I took. But, this is a working setup. Anyway, I loaded keystone/python keystone and the install gives me no errors. I am running Postgres, so I changed the driver in the the keystone.conf file accordingly.

Anyway, when I try to do a service create (after creating users and databases and setting rules), I get an error saying that I cannot get to Postgres at address 10.10.10.51, port 5432. Since my address is 150.150.1.1, that makes sense. SO, I checked, rechecked, and rechecked the config files in /etc/keystone and there is NO reference to this address. Nor in rabbitmq, nor in the database that I can find. Is there somewhere I am missing? I will probably have to go back to the distribution, but the last quantum changes croaked me so bad, I am very concerned about that avenue.

Thanks, and Merry Christmas, or whatever you choose to celebrate.

OldParrothead

edit retag flag offensive close merge delete

Comments

What is the value of OS_AUTH_URL in your environment? Are there existing endpoints registered in your keystone database?

larsks gravatar imagelarsks ( 2013-12-24 08:44:55 -0500 )edit

Will recheck this later on this week. Thanks. I may have been using an admin logon/password that was not created yet. But, thought the token bypassed that. IP address is OS_AUTH_URL is correct. As I said, will be getting back to this later in week.

OldParrothead gravatar imageOldParrothead ( 2013-12-26 07:01:41 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-01-06 12:32:54 -0500

OldParrothead gravatar image

updated 2014-01-07 09:09:17 -0500

After much research, and some well-deserved days off (shoveling 2 ft of snow), what I found is a mismatch in the password for the admin user. However, shouldn't I have gotten a different error? I chased my tail for a long time looking for an IP issue instead of the real problem.

Caveat to others, this could happen to you..

T

Added per request (Jan 7th)

The user which was not proper was the admin user which was in the openrc/creds file. It was not created at all (script failure), even though all others were.

BTW, the scripts posted for postgres installation out there (do Google search if immediate need, will post later) work great. I also have a document partially written for conversion/installation to Postgres if anyone is interested, please email to me and I will get back to them by end of week, once user/password redactions can be completed.

edit flag offensive delete link more

Comments

Which password was wrong? In Postgres? Were postgresql logs giving any suggestion that the password for admin was wrong?

smaffulli gravatar imagesmaffulli ( 2014-01-06 14:13:24 -0500 )edit

No to pg logs, see edit to post for rest.

OldParrothead gravatar imageOldParrothead ( 2014-01-07 09:09:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-24 07:10:39 -0500

Seen: 106 times

Last updated: Jan 07 '14