Ask Your Question
0

-bash: openstack-service: command not found

asked 2016-07-06 12:03:11 -0500

udayutkarsh gravatar image

I have installed 3- node setup, controller, network and compute node. One controller and compute node i can see the openstack service status using "openstack-service status" command but this command is not working on network node. I have install openstack using RDO (using packstack tool ) on rhel-7.1 os. Any suggestion??

I think "openstack" command is different from openstack-service start/restart/status" commands. As I have install python-openstackclient pkg on my network node but still openstack-service command is flashing same error. Actually I want to see all services running in network node. Is there any alternative to do that? on my compute node::

[root@compute ~]# openstack-service status MainPID=2188 Id=neutron-openvswitch-agent.service ActiveState=active MainPID=945 Id=openstack-ceilometer-compute.service ActiveState=active MainPID=2186 Id=openstack-nova-compute.service ActiveState=active

But on my network node::

[root@network ~]# openstack-service status -bash: openstack-service: command not found [root@network ~]#

edit retag flag offensive close merge delete

Comments

Do you check your own questions been posted 3 hr ago or you are only asking ?
https://ask.openstack.org/en/question...

dbaxps gravatar imagedbaxps ( 2016-07-06 12:20:16 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-11-28 07:20:48 -0500

udayutkarsh gravatar image
I fixed it by installing openstack-utils package:

sudo yum install openstack-utils

then both commands openstack-service and openstack-status started working
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-07-06 12:03:11 -0500

Seen: 1,585 times

Last updated: Nov 28 '17