Ask Your Question
0

can't start openvswitch and packstack install failed

asked 2016-06-30 11:11:33 -0600

Shotaro gravatar image

I tried to install mitaka on CentOS7 in VirtualBox.

Created answer-file and execute packstack --answer-file answer-file.txt.

But openvswitch is failed. I'm not sure which setting is wrong. So could you please help me.

192.168.56.100_neutron.pp: [ ERROR ] Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.56.100_neutron.pp Error: Could not start Service[openvswitch]: Execution of '/usr/bin/systemctl start openvswitch' returned 1: A d ependency job for openvswitch.service failed. See 'journalctl -xe' for details. You will find full trace in log /var/tmp/packstack/20160701-003425-z2zZJc/manifests/192.168.56.100_neutron.pp.lo g Please check log file /var/tmp/packstack/20160701-003425-z2zZJc/openstack-setup.log for more information Additional information: * File /root/keystonerc_admin has been created on OpenStack client host 192.168.56.100. To use the command line tools you need to source the file. * To access the OpenStack Dashboard browse to http://192.168.56.100/dashboard . Please, find your login credentials stored in the keystonerc_admin in your home directory. * To use Nagios, browse to http://192.168.56.100/nagios username: nagiosadmin, password: 5ff23ad1c7e34909

/usr/bin/systemctl

openvswitch-nonetwork.service loaded failed failed Open vSwitch Internal Unit

yum list installed

openvswitch.x86_64 2.5.0-2.el7

lsmod | grep openvswitch

openvswitch 84543 0 libcrc32c 12644 2 xfs,openvswitch

getenforce

Permissive

service openvswitch restart

Redirecting to /bin/systemctl restart openvswitch.service A dependency job for openvswitch.service failed. See 'journalctl -xe' for details.

ip a

1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: enp0s3: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:0e:cf:22 brd ff:ff:ff:ff:ff:ff inet 10.0.2.15/24 brd 10.0.2.255 scope global dynamic enp0s3 valid_lft 85481sec preferred_lft 85481sec inet6 fe80::a00:27ff:fe0e:cf22/64 scope link valid_lft forever preferred_lft forever 3: enp0s8: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:49:b0:f6 brd ff:ff:ff:ff:ff:ff inet 192.168.56.100/24 brd 192.168.56.255 scope global enp0s8 valid_lft forever preferred_lft forever inet6 fe80::a00:27ff:fe49:b0f6/64 scope link valid_lft forever preferred_lft forever

edit retag flag offensive close merge delete

Comments

one more info. when i do journalctl -xe, belew error is displayed. So when /var/run/openvswitch/db.sock is made usually? I couldn't find /var/run/openstack

Shotaro gravatar imageShotaro ( 2016-07-02 01:19:53 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-06-30 22:39:37 -0600

Can you re-run the packstack installation again.. Are you using centos-mitaka release.. If it fails again , then try not setting the br-ex : enp0s3 configuration and run the answer file again. You can later add the br port when u assign the IP from enp0s3 to br-ex interface.

edit flag offensive delete link more

Comments

Thanks for your comment, ,I'm using mitaka. My ovs setting is all "default". I re-run packstack but same result. CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS= CONFIG_NEUTRON_OVS_BRIDGE_IFACES=br= CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE= CONFIG_NEUTRON_OVS_TUNNEL_IF= CONFIG_NEUTRON_OVS_VXLAN_UDP_PORT=47

Shotaro gravatar imageShotaro ( 2016-07-02 01:04:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-06-30 11:11:33 -0600

Seen: 1,064 times

Last updated: Jun 30 '16