Ask Your Question
0

[RDO] Can not install Mitaka setting LinuxBridge as L2 agent

asked 2016-06-30 04:08:05 -0500

mhban gravatar image

updated 2016-06-30 04:09:31 -0500

I've tried to install Mitaka use packstack in RDO but failed with error below.

Full Trace:
2016-06-27 21:42:08::ERROR::run_setup::1018::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 1013, in main
    _main(options, confFile, logFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 660, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 627, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 81, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 109, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 50, in run
    self.function(config, messages)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/neutron_350.py", line 906, in create_l2_agent_manifests
    no_local_types = set(ovs_type) & set(['gre', 'vxlan', 'vlan', 'flat'])
UnboundLocalError: local variable 'ovs_type' referenced before assignment

[Environment]

RedHat 7.2 + RDO Mitaka (latest)
$ packstack --version
packstack Mitaka 8.0.0

Here's brief setting in answer file.

# grep -i "ML2\|AGENT\|OPENV\|OVS" mit-answer-file2016-06-27.cfg |grep -v "^#"
CONFIG_NEUTRON_METERING_AGENT_INSTALL=y
CONFIG_NEUTRON_ML2_TYPE_DRIVERS=flat,vlan
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=vlan
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS=linuxbridge
CONFIG_NEUTRON_ML2_FLAT_NETWORKS=*
CONFIG_NEUTRON_ML2_VLAN_RANGES=physnet1:100:120
CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES=
CONFIG_NEUTRON_ML2_VXLAN_GROUP=
CONFIG_NEUTRON_ML2_VNI_RANGES=10:100
CONFIG_NEUTRON_L2_AGENT=linuxbridge
CONFIG_NEUTRON_ML2_SUPPORTED_PCI_VENDOR_DEVS=['15b3:1004', '8086:10ca']
CONFIG_NEUTRON_ML2_SRIOV_AGENT_REQUIRED=n
CONFIG_NEUTRON_ML2_SRIOV_INTERFACE_MAPPINGS=
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=
CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE=
CONFIG_NEUTRON_OVS_TUNNEL_IF=
CONFIG_NEUTRON_OVS_TUNNEL_SUBNETS=
CONFIG_NEUTRON_OVS_VXLAN_UDP_PORT=4789
CONFIG_PROVISION_OVS_BRIDGE=n

I opened launchpad bug on https://bugs.launchpad.net/packstack/+bug/1597653 (https://bugs.launchpad.net/packstack/...)

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2016-06-30 04:23:11 -0500

jckreddy gravatar image
As you  enabling LinuxBridge as L2 agent
please check whether you updated the below config 
 type_drivers = flat
tenant_network_types = flat
#mechanism_drivers = openvswitch  <<< Should be commented /removed for linuxbridge
mechanism_drivers = linuxbridge

This is config in ml2_conf.ini  for manual installation 

I think same type of config need to be checked with packstack also
edit flag offensive delete link more

Comments

Thanks for comment and yes I know how to setup manually but I just want to use Packstack to install OpenStack. As you see above, I already set CONFIG_NEUTRON_ML2_TYPE_DRIVERS=flat,vlan in answer file.

mhban gravatar imagemhban ( 2016-07-01 09:15:07 -0500 )edit

why you are using ovs if you are planning to have flat network i do prefer should use nova network instead of neutron

billy gravatar imagebilly ( 2016-07-04 20:48:56 -0500 )edit

Thanks for your interest but I use not just flat but also all others. Nova network is not going to be my option.

mhban gravatar imagemhban ( 2016-07-09 09:33:52 -0500 )edit
0

answered 2016-07-09 09:35:32 -0500

mhban gravatar image

Reviewed: https://review.openstack.org/336450 Committed: https://git.openstack.org/cgit/openstack/packstack/commit/?id=bbf0a02e2f9c1e29cc62b3fa133c67abb01afc9d (https://git.openstack.org/cgit/openst...) Submitter: Jenkins Branch: master

commit bbf0a02e2f9c1e29cc62b3fa133c67abb01afc9d Author: Javier Pena jpena@redhat.com Date: Fri Jul 1 11:22:00 2016 +0200

Fix LinuxBridge support

https://review.openstack.org/307403 added a regression in LinuxBridge
support, as it always used the ovs_type variable, which was only
set when OVS was used.

Change-Id: I80da8d999ece2fd4c5a4f7ad801d56236a30664e
Closes-Bug: #1597653

Changed in packstack: status: Confirmed → Fix Released

edit flag offensive delete link more
0

answered 2016-07-09 10:25:56 -0500

dbaxps gravatar image

updated 2016-07-09 10:50:24 -0500

Seems to be fixed bug https://bugs.launchpad.net/packstack/...
Have you backported patch
https://review.openstack.org/gitweb?p... to RDO Mitaka stable ?
Double check which rpm belongs packstack/plugins/neutron_350.py via rpm -qf
I don't have packstack'ed RDO Mitaka Controller around .
My guess it should be openstack-packstack-8.0.0-1.el7.src.rpm

to the most recent stable version openstack-packstack-8.0.0-(X).el7.src.rpm (should be X=1)
but double check.Then apply mentioned patch and rebuild src.rpm , what will generate new RPMS
sudo yum install openstack-packstack-8.0.0-(X+1).el7.centos.noarch.rpm \
openstack-packstack-doc-8.0.0-(X+1).el7.centos.noarch.rpm \
openstack-packstack-puppet-8.0.0-(X+1).el7.centos.noarch.rpm

Either just patch packstack/plugins/neutron_350.py manually. Just make sure that at the moment patch as of 07/01/16 maybe applied cleanly , might be not . If patch applies cleanly then run packstack as suggested.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-06-30 04:08:05 -0500

Seen: 696 times

Last updated: Jul 09 '16