tox -e genconfig "ERROR: genconfig...

asked 2016-06-28 20:40:16 -0600

Please help with this error when running "tox -e genconfig"

"ERROR: genconfig: could not install deps [-r/home/....."

How can I generate my config file with "tox -e genconfig" as mentioned here: http://docs.openstack.org/developer/kolla/image-building.html#generating-kolla-build-conf (http://docs.openstack.org/developer/k...)

This is preventing the "kolla-build" command from working so it seems.

I'm running Ubuntu Server on KVM

edit retag flag offensive close merge delete

Comments

Tox will create config files but kolla-build command should exist just installing kolla

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-06-29 01:39:17 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2016-06-29 03:32:57 -0600

You can give this a try:

rm -rf .tox # remove everything tox ever did here
sudo pip install --upgrade pip tox virtualenv  # upgrade your tooling (maybe use 'sudo -H ')
tox -e genconfig  # try to build the conf file again
edit flag offensive delete link more

Comments

installation of tox through pip not apt get works for me thank you!

syjeong gravatar imagesyjeong ( 2018-10-18 04:08:32 -0600 )edit
0

answered 2018-07-25 04:36:34 -0600

srihitha gravatar image

Even i faced same issue but when i tried option u gave in answer i tried it later again i am facing different issue:

ERROR: genconfig: Error creating virtualenv. Note that some special characters (e.g. ':' and unicode symbols) in paths are not supported by virtualenv.

can someone help me to solve this issue.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-06-28 20:40:16 -0600

Seen: 1,162 times

Last updated: Jul 25 '18