"url_helper.py" Need to disable these messages

asked 2016-06-27 19:30:25 -0600

amit-g gravatar image

Hello Team,

I am working on the network configuration, where I have configured and external network of the subnet 10.209.82.x and have attached an Instance (RHEL 6.0) directly to this network and have assigned it with floating IP. However, on booting the instance I keep getting following message "url_helper.py[WARNING]:Calling '' failied " , which in turns delays the booting of machine. Is there a way to disable this message.


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-06-29 16:11:08 -0600

mpetason gravatar image

You'll need to launch your instances on an internal network so that they can access dhcp and metadata. External networks are there to use for Floating IP addresses.

Floating IP > NAT > Internal IP

Public networks should be created in the Admin tenant.

You'll want to work out of another tenant, say create one called "demo" like the guides, or create a tenant based on the project you are working on. From that point you can create an internal network for the tenant. You'll launch the instance on the internal network in the new tenant.

The issue with using the Admin tenant is that you're able to see all of the resources available. You aren't meant to launch instances on an External network (at least not out of the box.) DHCP is supposed to be disabled on the Public Network as well (external network.)

edit flag offensive delete link more


Thanks for the reply. Presently, I just managed to get rid of these messages by removing packages with cloud-init.

amit-g gravatar imageamit-g ( 2016-06-30 11:26:55 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-06-27 19:30:25 -0600

Seen: 606 times

Last updated: Jun 29 '16