Floating-ips on Devstack installation

asked 2016-06-27 04:23:07 -0600

trikelef gravatar image

updated 2016-07-01 08:37:36 -0600

I am trying to install Devstack (from git master) on a single vagrant based ubuntu running on Virtualbox. Initially I have only a NAT adapter and running stach.sh as stack user using the following local.conf finishes sucessfully (i.e. I can log into dashboard and create instances etc).

[[local|localrc]]


ADMIN_PASSWORD=nomoresecret
DATABASE_PASSWORD=stackdb
RABBIT_PASSWORD=stackqueue
SERVICE_PASSWORD=$ADMIN_PASSWORD

HOST_IP=10.0.2.15
FLAT_INTERFACE=eth0
FLOATING_RANGE=10.0.2.224/28

LOGFILE=$DEST/logs/stack.sh.log
LOGDAYS=2

CINDER_BRANCH=milestone-proposed
GLANCE_BRANCH=milestone-proposed
HORIZON_BRANCH=milestone-proposed
KEYSTONE_BRANCH=milestone-proposed
KEYSTONECLIENT_BRANCH=milestone-proposed
NOVA_BRANCH=milestone-proposed
NOVACLIENT_BRANCH=milestone-proposed
NEUTRON_BRANCH=milestone-proposed
SWIFT_BRANCH=milestone-proposed

disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service neutron
enable_service tempest

enable_plugin neutron-lbaas https://git.openstack.org/openstack/neutron-lbaas


SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5

SWIFT_REPLICAS=1

SWIFT_DATA_DIR=$DEST/data

However when I run the exercise.sh I get the following issues:

+functions:ping_check:425                  local 'check_command=while  /home/vagrant/devstack/tools/ping_neutron.sh 30 -c1 -w1 fda4:7560:1de4:0:f816:3eff:fe07:adad,; do sleep 1; done'
+functions:ping_check:426                  echo 'Checking connectivity with while  /home/vagrant/devstack/tools/ping_neutron.sh 30 -c1 -w1 fda4:7560:1de4:0:f816:3eff:fe07:adad,; do sleep 1; done'
Checking connectivity with while  /home/vagrant/devstack/tools/ping_neutron.sh 30 -c1 -w1 fda4:7560:1de4:0:f816:3eff:fe07:adad,; do sleep 1; done
+functions:ping_check:428                  timeout 10.0.0.7 sh -c 'while  /home/vagrant/devstack/tools/ping_neutron.sh 30 -c1 -w1 fda4:7560:1de4:0:f816:3eff:fe07:adad,; do sleep 1; done'
timeout: invalid time interval '10.0.0.7'
Try 'timeout --help' for more information.
+functions:ping_check:429                  die 429 '[Fail]' Could ping server
+functions-common:die:186                  local exitcode=0
+functions-common:die:187                  set +o xtrace
[Call Trace]
/home/vagrant/devstack/exercises/volumes.sh:147:ping_check
/home/vagrant/devstack/functions:429:die
[ERROR] /home/vagrant/devstack/functions:429 [Fail] Could ping server
=====================================================================
SKIP swift
PASS aggregates
PASS client-args
PASS client-env
PASS sec_groups
FAILED boot_from_volume
FAILED floating_ips
FAILED neutron-adv-test
FAILED volumes
=====================================================================

I have also tried to run stack with several combinations of adapters (Host-only), IP configurations on local.conf and even tried another Linux distro (CentOS 7).

Is there any other OS-wide or Devstack configuration that I should follow in order to make networking work without problems?

edit retag flag offensive close merge delete