Ask Your Question
0

openstack container create container1 - Not Found (HTTP 404)

asked 2016-06-20 08:17:27 -0500

jgiardina gravatar image

updated 2016-06-20 14:35:00 -0500

Following the Mitaka guide on Ubuntu here:

http://docs.openstack.org/mitaka/install-guide-ubuntu/swift-verify.html (http://docs.openstack.org/mitaka/inst...)

I am running into a HTTP 404 when trying to create the first container:

# . demo-openrc
# openstack container create container1 Not Found (HTTP 404)

...and a debug:

openstack container create container1

Not Found (HTTP 404)

# openstack container create container1 --debug START with options: ['container', 'create', 'container1', '--debug'] options: Namespace(access_token_endpoint='', auth_type='', auth_url='http://controller01:5000/v3', cacert='', client_id='', client_secret='***', cloud='', debug=True, default_domain='default', deferred_help=False, domain_id='', domain_name='', endpoint='', identity_provider='', identity_provider_url='', insecure=None, interface='', log_file=None, os_compute_api_version='', os_dns_api_version='2', os_identity_api_version='3', os_image_api_version='2', os_key_manager_api_version='1', os_network_api_version='', os_object_api_version='', os_orchestration_api_version='1', os_project_id=None, os_project_name=None, os_volume_api_version='', password='***', profile=None, project_domain_id='', project_domain_name='default', project_id='', project_name='demo', protocol='', region_name='', scope='', service_provider_endpoint='', timing=False, token='***', trust_id='', url='', user_domain_id='', user_domain_name='default', user_id='', username='demo', verbose_level=3, verify=None) defaults: {u'auth_type': 'password', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'api_timeout': None, u'baremetal_api_version': u'1', u'image_api_version': u'2', 'cacert': None, u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': u'1', u'interface': None, u'network_api_version': u'2', u'image_format': u'qcow2', u'key_manager_api_version': u'v1', u'metering_api_version': u'2', 'verify': True, u'identity_api_version': u'2.0', u'volume_api_version': u'2', 'cert': None, u'secgroup_source': u'neutron', u'container_api_version': u'1', u'dns_api_version': u'2', u'object_store_api_version': u'1', u'disable_vendor_agent': {}} cloud cfg: {'auth_type': 'password', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'timing': False, u'network_api_version': u'2', u'image_format': u'qcow2', u'image_api_version': '2', 'verify': True, u'dns_api_version': '2', u'object_store_api_version': u'1', 'verbose_level': 3, 'region_name': '', 'api_timeout': None, u'baremetal_api_version': u'1', 'auth': {'username': 'demo', 'project_name': 'demo', 'user_domain_name': 'default', 'auth_url': 'http://controller01:5000/v3', 'password': '***', 'project_domain_name': 'default'}, 'default_domain': 'default', u'container_api_version': u'1', u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': '1', u'interface': None, 'cacert': None, u'key_manager_api_version': '1', u'metering_api_version': u'2', 'deferred_help': False, u'identity_api_version': '3', u'volume_api_version': u'2', 'cert': None, u'secgroup_source': u'neutron', 'debug': True, u'disable_vendor_agent': {}} compute API version 2, cmd group openstack.compute.v2 network API version 2, cmd group openstack.network.v2 image API version 2, cmd group openstack.image.v2 volume API version 2, cmd group openstack.volume.v2 identity API version 3, cmd group openstack.identity.v3 object_store API version 1, cmd group openstack.object_store.v1 dns API version 2, cmd group openstack.dns.v2 key_manager API version 1, cmd group openstack.key_manager.v1 orchestration API version 1, cmd group openstack.orchestration.v1 command: container create -> openstackclient.object.v1.container.CreateContainer Auth plugin password selected auth_type: password Using auth plugin: password Using parameters {'username': 'demo', 'project_name': 'demo', 'auth_url': 'http://controller01:5000/v3', 'user_domain_name': 'default', 'password': '***', 'project_domain_name': 'default'} Get auth_ref REQ: curl -g -i -X GET http://controller01:5000/v3 -H "Accept: application/json" -H "User-Agent: python-openstackclient keystoneauth1/2.4.0 python-requests/2.9.1 CPython/2.7.6" Starting new HTTP connection (1): controller01 "GET /v3 HTTP/1.1" 200 251 RESP: [200] Content-Length ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-06-23 06:14:21 -0500

jgiardina gravatar image

I found the issue with the accounts file being incorrect on my storage nodes. I recreated the account.builder files after removing the previous ones and recreated the initial rings. I was then able to create containers/files in swift.

edit flag offensive delete link more
0

answered 2019-03-18 14:41:56 -0500

slavonic gravatar image

In my case, it was a misconfiguration during ring creation. I forgot to change --port 6202 option for container.builder and object.builder. It's working fine after reconfiguration.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-06-20 07:56:56 -0500

Seen: 1,029 times

Last updated: Jun 23 '16