Ask Your Question

Adding new compute nodes

asked 2016-06-19 20:19:36 -0500

Lee gravatar image

Hi All,

I already deployed the openstack on servers (say controller0 and compute0).

I want to add compute node (say compute1) to run more instances.

When adding more compute node (compute1) it is the same compute node (compute0) configuration.

I change IP address of compute nods (compute0 and compute1).

I want to verify my compute node, I am not sure it works that way.

How to verify the compute nodes?


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-06-19 21:16:10 -0500

updated 2016-06-20 06:05:21 -0500

nova and neutron ip configuration change too.

you check nova.conf my_ip section.

and ml2_conf.ini or openvswitch_agent.ini file check.

Then compute1 service restart. (nova and neutron)

you can check all agent on controller node. (nova service-list / neutron agent-list)

you can find compute1 state.

compute1 configuration.

  • nova.conf

First copy nova.conf in compute0.

Second change my_ip section. (my_ip =

  • ml2_conf.ini

First copy ml2_conf.ini in compute0.

Second change local_ip section. (local_ip = {TUNNEL IP,})

edit flag offensive delete link more


Thanks. Your suggestion worked for me. I already change your suggestion. The compute nodes is normal for the state. I do not sure how to make an instance according to the compute nodes. Do you have any idea? Thanks!

Lee gravatar imageLee ( 2016-06-20 00:22:20 -0500 )edit

Oh... you want create instance on choose compute node?

if you create instance to specific compute node, you using nova CLI...

for example $ nova boot --image <uuid> --flavor m1.tiny --key_name test --availability_zone=nova:hostname

if you using horizon you can check instance count (over 2)...

uni2u gravatar imageuni2u ( 2016-06-20 02:24:15 -0500 )edit

Thanks. The instances are created on original compute node (compute0). However, the additional compute node (compute1) was not created for making instance. When i show the dashboard (horizon) for the state of new instance, it is still scheduling. I think that it is network problems.

Lee gravatar imageLee ( 2016-06-20 03:04:23 -0500 )edit

I deleted the configure rabbitMQ in neutron.conf on additional compute node (compute1).

I can be changed into the following:

//rpc_backend = rabbit

rabbit_host = controller

rabbit_password = RABBIT_PASS

If i do not delete the rpc_backend, neutron-plugin-openvswitch-agent is still wating.

Lee gravatar imageLee ( 2016-06-20 03:10:29 -0500 )edit

The ip of the nodes are as follows:

*one compute node (compute0):



*another compute node (compute1):


local_ip in ml2_conf.ini:

Lee gravatar imageLee ( 2016-06-20 03:22:51 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-06-19 20:19:36 -0500

Seen: 556 times

Last updated: Jun 20 '16