Ask Your Question
0

Unable to start Ceilometer services

asked 2016-06-18 13:30:06 -0500

Alex Usov gravatar image

updated 2016-08-18 14:17:01 -0500

rbowen gravatar image

Hello everyone.

Trying to set up Ceilometer on controller node, as described in http://docs.openstack.org/mitaka/inst... , I ran into a problem - services don't start and logs show the following:

Jun 18 21:21:10 openstack-01.svp.test ceilometer-api[21573]: File "/usr/lib/python2.7/site-packages/oslo_config/types.py", line 158, in __repr__
Jun 18 21:21:10 openstack-01.svp.test ceilometer-api[21573]: details.append("choices=%r" % self.choices)
Jun 18 21:21:10 openstack-01.svp.test ceilometer-api[21573]: TypeError: not all arguments converted during string formatting

I double-checked ceilometer.conf and it seems correct. Is this a bug or am I missing something?

P.S.: I am using OpenStack Mitaka release and CentOS 7 on all nodes. Here are the versions of all 4 components:

ceilometer-api: 6.0.0;
ceilometer-collector: 6.0.0;
ceilometer-agent-notification: 6.0.0;
ceilometer-polling (openstack-ceilometer-central): 6.0.0;

Below is my ceilometer.conf without comments:

[DEFAULT]
auth_strategy = keystone
rpc_backend = rabbit
[api]
[central]
[collector]
[compute]
[coordination]
[cors]
[cors.subdomain]
[database]
connection = mongodb://ceilometer:**********@openstack-01.svp.test:27017/ceilometer
[dispatcher_file]
[dispatcher_gnocchi]
[event]
[exchange_control]
[hardware]
[ipmi]
[keystone_authtoken]
auth_uri = http://openstack-01.svp.test:5000
auth_url = http://openstack-01.svp.test:35357
memcached_servers = openstack-01.svp.test:11211
auth_type = password
project_name = service
project_domain_name = default
user_domain_name = default
username = ceilometer
password = **********
[matchmaker_redis]
[meter]
[notification]
[oslo_concurrency]
[oslo_messaging_amqp]
[oslo_messaging_notifications]
[oslo_messaging_rabbit]
rabbit_host = openstack-01.svp.test
rabbit_userid = openstack
rabbit_password = **********
[oslo_policy]
[polling]
[publisher]
[publisher_notifier]
[rgw_admin_credentials]
[service_credentials]
auth_url = http://openstack-01.svp.test:5000/v3
auth_type = password
project_name = service
project_domain_name = default
user_domain_name = default
username = ceilometer
password = **********
region_name = RegionOne
interface = http://openstack-01.svp.test:8777
[service_types]
[storage]
[vmware]
[xenapi]
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-08-20 08:56:38 -0500

Alex Usov gravatar image

updated 2016-08-20 08:57:44 -0500

Thanks for answering! I installed openstack-aodh-package, edited /etc/aodh/aodh.conf similarly to /etc/ceilometer/ceilometer.conf, and then ran aodh-dbsync, but services still won't start. Do you have something else in mind? P.S.: in case it matters, I noticed that mongodb contains only ceilometer database with alarm and alarm_history collections - both of them are empty.

edit flag offensive delete link more

Comments

1

I note that under the [service_credentials] you have interface=http://openstack-01.svp.test:8777. Change that to interface=internalURL and restart ceilometer services.

barry.davis gravatar imagebarry.davis ( 2016-08-21 16:57:18 -0500 )edit
1

It worked, thanks! Shame on me for my inobservance.

Alex Usov gravatar imageAlex Usov ( 2016-08-22 06:15:39 -0500 )edit
0

answered 2016-08-18 17:03:01 -0500

Documentation is missing database population.
You will need to run aodh-dbsync on the controller node to create the database tables.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-06-18 13:30:06 -0500

Seen: 279 times

Last updated: Aug 20 '16