Ask Your Question
3

can't enable ml2: Neutron "unexpected keyword argument 'name_order'"

asked 2013-12-23 02:49:24 -0500

chen-li gravatar image

updated 2013-12-27 12:59:39 -0500

smaffulli gravatar image

Hi list,

I'm working under CentOS 6.4 + Havana:

openstack-neutron.noarch 2013.2.1-1.el6 @openstack-havana
openstack-neutron-linuxbridge.noarch 2013.2.1-1.el6 @openstack-havana
openstack-neutron-ml2.noarch 2013.2.1-1.el6 @openstack-havana
openstack-neutron-openvswitch.noarch 2013.2.1-1.el6 @openstack-havana
python-neutron.noarch 2013.2.1-1.el6 @openstack-havana
python-neutronclient.noarch 2.3.1-1.el6 @openstack-havana

Everything works when I was working under core_plugin = Neutron.plugins.openvswitch.ovs_neutron_plugin.OVSNeutronPluginV2

While after I set core_plugin = neutron.plugins.ml2.plugin.Ml2Plugin I can't start neutron-server.

The log in /var/log/neutron/server.log is :

2013-12-23 08:35:00.660 37948 INFO neutron.common.config [-] Logging enabled!
2013-12-23 08:35:00.661 37948 ERROR neutron.common.legacy [-] Skipping unknown group key: firewall_driver
2013-12-23 08:35:00.664 37948 INFO neutron.common.config [-] Config paste file: /etc/neutron/api-paste.ini
2013-12-23 08:35:00.693 37948 INFO neutron.manager [-] Loading Plugin: neutron.plugins.ml2.plugin.Ml2Plugin
2013-12-23 08:35:00.735 37948 INFO neutron.plugins.ml2.managers [-] Configured type driver names: ['local', 'flat', 'vlan', 'gre', 'vxlan']
2013-12-23 08:35:00.750 37948 INFO neutron.plugins.ml2.drivers.type_flat [-] Allowable flat physical_network names: []
2013-12-23 08:35:00.752 37948 INFO neutron.plugins.ml2.drivers.type_vlan [-] Network VLAN ranges: {}
2013-12-23 08:35:00.752 37948 INFO neutron.plugins.ml2.drivers.type_local [-] ML2 LocalTypeDriver initialization complete
2013-12-23 08:35:00.758 37948 INFO neutron.plugins.ml2.managers [-] Loaded type driver names: ['flat', 'vlan', 'local', 'gre', 'vxlan']
2013-12-23 08:35:00.758 37948 INFO neutron.plugins.ml2.managers [-] Registered types: ['flat', 'vlan', 'local', 'gre', 'vxlan']
2013-12-23 08:35:00.758 37948 INFO neutron.plugins.ml2.managers [-] Tenant network_types: ['local', 'flat', 'vlan', 'gre', 'vxlan']
2013-12-23 08:35:00.758 37948 INFO neutron.plugins.ml2.managers [-] Configured mechanism driver names: ['openvswitch', 'linuxbridge']
2013-12-23 08:35:00.759 37948 ERROR neutron.service [-] Unrecoverable error: please check log for details.
2013-12-23 08:35:00.759 37948 TRACE neutron.service Traceback (most recent call last):
2013-12-23 08:35:00.759 37948 TRACE neutron.service File "/usr/lib/python2.6/site-packages/neutron/service.py", line 99, in serve_wsgi
2013-12-23 08:35:00.759 37948 TRACE neutron.service service.start()
2013-12-23 08:35:00.759 37948 TRACE neutron.service File "/usr/lib/python2.6/site-packages/neutron/service.py", line 68, in start
2013-12-23 08:35:00.759 37948 TRACE neutron.service self.wsgi_app = _run_wsgi(self.app_name)
2013-12-23 08:35:00.759 37948 TRACE neutron.service File "/usr/lib/python2.6/site-packages/neutron/service.py", line 112, in _run_wsgi
2013-12-23 08:35:00.759 37948 TRACE neutron.service app = config.load_paste_app(app_name)
2013-12-23 08:35:00.759 37948 TRACE neutron.service File "/usr/lib/python2.6/site-packages/neutron/common/config.py", line 144, in load_paste_app
2013-12-23 08:35:00.759 37948 TRACE neutron.service app = deploy.loadapp("config:%s" % config_path, name=app_name)
2013-12-23 08:35:00.759 37948 TRACE neutron.service File "/usr/lib/python2.6/site-packages/PasteDeploy-1.5.0-py2.6.egg/paste/deploy/loadwsgi.py", line 247, in loadapp
2013-12-23 08:35:00.759 37948 TRACE neutron.service ...
(more)
edit retag flag offensive close merge delete

Comments

1

https://ask.openstack.org/en/question/6695/ml2-neutron-plugin-installation-and-configuration/ have a look at this discussion, it may contain useful hints for you. If you find a solution please add it to the answer below.

smaffulli gravatar imagesmaffulli ( 2013-12-27 13:04:38 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-01-06 12:34:04 -0500

rbowen gravatar image

This was also logged as a bug at https://bugs.launchpad.net/neutron/+bug/1263637 and then closed as invalid, with the solution stating that the problem is the version of Stevedore which is running, and that upgrading Stevedore to >0.12 resolved the issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-12-23 02:49:24 -0500

Seen: 389 times

Last updated: Jan 06 '14